404 downloading cliff

Bug #1366860 reported by Derek Higgins on 2014-09-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Critical
Derek Higgins

Bug Description

tripleo CI failure
started 2014-09-08 14:25:40 UTC

http://logs.openstack.org/81/119381/3/check-tripleo/check-tripleo-novabm-overcloud-f20-nonha/55b77d4/console.html

2014-09-08 14:56:50.211 | Downloading/unpacking cliff>=1.6.0 (from python-neutronclient>=2.3.5,<3->-r /opt/stack/heat/requirements.txt (line 24))
2014-09-08 14:56:50.263 | http://pypi.openstack.org/simple/cliff/ uses an insecure transport scheme (http). Consider using https if pypi.openstack.org has it available
2014-09-08 14:56:50.314 | HTTP error 404 while getting http://pypi.openstack.org/packages/source/c/cliff/cliff-1.7.0.tar.gz#md5=0d76f9b73d70ba3874ac0de734a3185d (from http://pypi.openstack.org/simple/cliff/)
2014-09-08 14:56:50.315 | Cleaning up...
2014-09-08 14:56:50.459 | Exception:
2014-09-08 14:56:50.459 | Traceback (most recent call last):
2014-09-08 14:56:50.460 | File "/opt/stack/venvs/openstack/lib/python2.7/site-packages/pip/basecommand.py", line 122, in main
2014-09-08 14:56:50.460 | status = self.run(options, args)
2014-09-08 14:56:50.460 | File "/opt/stack/venvs/openstack/lib/python2.7/site-packages/pip/commands/install.py", line 278, in run
2014-09-08 14:56:50.461 | requirement_set.prepare_files(finder, force_root_egg_info=self.bundle, bundle=self.bundle)
2014-09-08 14:56:50.461 | File "/opt/stack/venvs/openstack/lib/python2.7/site-packages/pip/req.py", line 1197, in prepare_files
2014-09-08 14:56:50.461 | do_download,
2014-09-08 14:56:50.461 | File "/opt/stack/venvs/openstack/lib/python2.7/site-packages/pip/req.py", line 1375, in unpack_url
2014-09-08 14:56:50.462 | self.session,
2014-09-08 14:56:50.462 | File "/opt/stack/venvs/openstack/lib/python2.7/site-packages/pip/download.py", line 547, in unpack_http_url
2014-09-08 14:56:50.462 | resp.raise_for_status()
2014-09-08 14:56:50.463 | File "/opt/stack/venvs/openstack/lib/python2.7/site-packages/pip/_vendor/requests/models.py", line 795, in raise_for_status
2014-09-08 14:56:50.463 | raise HTTPError(http_error_msg, response=self)
2014-09-08 14:56:50.463 | HTTPError: 404 Client Error: Not Found
2014-09-08 14:56:50.464 |

Tags: ci Edit Tag help
Derek Higgins (derekh) wrote :

May have been just a glitch, will close if it doesn't happen again in the next few hours

James Slagle (james-slagle) wrote :

hi, derek, I assigned this one to you. I believe this was just a glitch, I haven't seen it today. Can you close this out if that's the case?

Changed in tripleo:
assignee: nobody → Derek Higgins (derekh)
Doug Hellmann (doug-hellmann) wrote :

We did release a new version of cliff this week, so let me know if there's something wrong with the package on pypi.

Derek Higgins (derekh) wrote :

Looks like the 404 must have been during the transition, I saw about 10 of them an then they went away

Changed in tripleo:
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers