overcloud CI : no user image

Bug #1366808 reported by Derek Higgins on 2014-09-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Glance Client
Undecided
Unassigned
tripleo
Critical
Derek Higgins

Bug Description

CI overcloud Failures started over the weekend

Last passing test was 2014-09-05 21:52:36 UTC

From
http://logs.openstack.org/23/119723/1/check-tripleo/check-tripleo-novabm-overcloud-f20-nonha/2088c14/console.html

2014-09-08 12:13:23.268 | ++ glance image-show user
2014-09-08 12:13:24.872 | No image with a name or ID of 'user' exists.
2014-09-08 12:13:24.886 | + IMAGE_ID=
2014-09-08 12:13:24.914 | + get_state_from_hosts
2014-09-08 12:13:24.914 | + get_state_from_host seed root@192.168.1.250

Tags: ci Edit Tag help
Derek Higgins (derekh) on 2014-09-08
description: updated
summary: - overcloud CI jobs failing
+ overcloud CI : no user image

Fix proposed to branch: master
Review: https://review.openstack.org/119761

Changed in tripleo:
assignee: nobody → Derek Higgins (derekh)
status: Triaged → In Progress
Derek Higgins (derekh) wrote :

Looks like a new version of glanceclient no longer supports the "--public" option,
https://review.openstack.org/#/c/108804/

Reviewed: https://review.openstack.org/119761
Committed: https://git.openstack.org/cgit/openstack/tripleo-incubator/commit/?id=988c55d0eb70fbc05e8dd6cc5de94c85b99855eb
Submitter: Jenkins
Branch: master

commit 988c55d0eb70fbc05e8dd6cc5de94c85b99855eb
Author: Derek Higgins <email address hidden>
Date: Mon Sep 8 14:44:40 2014 +0100

    Use "--is-public True" during image-create's

    A new glanceclient has been released that no longer supports the
    --public option.

    Change-Id: I8075271f894d16c9d090106b0d41ab9d3069400a
    Closes-Bug: #1366808

Changed in tripleo:
status: In Progress → Fix Released
Gregory Haynes (greghaynes) wrote :

I think this is actually just a bug in https://review.openstack.org/#/c/108804. The option is still there (and should error if it was actually removed) but it is just not being used.

Changed in tripleo:
status: Fix Released → Confirmed
Changed in tripleo:
status: Confirmed → Fix Released
Erno Kuvaja (jokke) wrote :

Bug is based on undocumented option that has been working and finally being cleaned out. --public was deprecated from glanceclient at 2012 and --is-public should have been used instead.

Changed in python-glanceclient:
status: New → Invalid
Derek Higgins (derekh) wrote :

I think gregs point is that the option is still in the code but is no longer being used
    http://git.openstack.org/cgit/openstack/python-glanceclient/tree/glanceclient/v1/shell.py?id=1dfce5301c5d7cd456c98629a007917120637c8a#n193

Also it wasn't deprecated, It was hidden in 2012 and then silently stopped working

Change abandoned by greghaynes (<email address hidden>) on branch: master
Review: https://review.openstack.org/119973

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers