Error parsing _stylesheets.html

Bug #1349774 reported by Derek Higgins on 2014-07-29
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
High
Radomir Dopieralski
tripleo
Critical
Unassigned

Bug Description

As of about 10 UTC last night, all tripleo jobs are failing

http://logs.openstack.org/60/104060/2/check-tripleo/check-tripleo-novabm-overcloud-f20-nonha/ebd8814/logs/overcloud-controller0_logs/os-collect-config.txt.gz

Jul 29 08:12:06 overcloud-controller0-6xxjtao24g7a os-collect-config[788]: dib-run-parts Tue Jul 29 08:12:06 UTC 2014 Running /opt/stack/os-config-refresh/post-configure.d/14-horizon
Jul 29 08:12:10 overcloud-controller0-6xxjtao24g7a os-collect-config[788]: CommandError: An error occured during rendering /opt/stack/venvs/openstack/lib/python2.7/site-packages/openstack_dashboard/templates/_stylesheets.html: Error parsing block:
Jul 29 08:12:10 overcloud-controller0-6xxjtao24g7a os-collect-config[788]: 1
Jul 29 08:12:10 overcloud-controller0-6xxjtao24g7a os-collect-config[788]: 2

Julie Pichon (jpichon) on 2014-07-29
tags: added: gate
Derek Higgins (derekh) wrote :

The revert of https://review.openstack.org/#/c/107042/ unblocked tripleo CI
we are now running tripleo CI with this revert applied

Also I've submitted a revert to horizon
https://review.openstack.org/#/c/110258/

Derek Higgins (derekh) wrote :

More info The stack trace ends in

From <string u'// bootstrap overrides:\n$icon-font-path: "/static/'...>:0
Traceback:
  File "/opt/stack/venvs/openstack/lib/python2.7/site-packages/scss/__init__.py", line 498, in manage_children
    self._manage_children_impl(rule, scope)
  File "/opt/stack/venvs/openstack/lib/python2.7/site-packages/scss/__init__.py", line 548, in _manage_children_impl
    self._do_import(rule, scope, block)
  File "/opt/stack/venvs/openstack/lib/python2.7/site-packages/django_pyscss/scss.py", line 118, in _do_import
    source_file = self._find_source_file(name, relative_to)
  File "/opt/stack/venvs/openstack/lib/python2.7/site-packages/django_pyscss/scss.py", line 89, in _find_source_file
    with storage.open(full_filename) as f:
  File "/opt/stack/venvs/openstack/lib/python2.7/site-packages/django/core/files/storage.py", line 33, in open
    return self._open(name, mode)
  File "/opt/stack/venvs/openstack/lib/python2.7/site-packages/django/core/files/storage.py", line 160, in _open
    return File(open(self.path(name), mode))
IOError: [Errno 21] Is a directory: u'/opt/stack/venvs/openstack/lib/python2.7/site-packages/openstack_dashboard/static/bootstrap/scss/bootstrap'

Justin Pomeroy (jpomero) wrote :

I'm also seeing this problem in my openstack distro build. I could be wrong but it seems to be this import statement from openstack_dashboard/static/dashboard/scss/horizon.scss:

@import "/bootstrap/scss/bootstrap";

I think the intent is to import the bootstrap.scss file but since there is also a folder called bootstrap in the same location it fails with the "IOError: [Errno 21] Is a directory" error. Maybe if the folder or file were just renamed?

Justin Pomeroy (jpomero) on 2014-07-30
Changed in horizon:
status: New → Confirmed
Julie Pichon (jpichon) wrote :

I wonder if there may be a relation with bug 1342079 (hardcoded /static/ prefixes), since the environments where this is happening don't use the default dev values?

Changed in horizon:
assignee: nobody → Gregory Haynes (greghaynes)
status: Confirmed → In Progress
Radomir Dopieralski (deshipu) wrote :

What I would like to know is why this is working just fine for everyone else.

Julie Pichon (jpichon) wrote :

I'm not sure how many people have tested the patch outside of devstack yet? I compared library version numbers with Derek but couldn't see any meaningful difference, I'm not sure what is causing the issue.

Gregory Haynes (greghaynes) wrote :

I imagine you meant devtest (not devstack), which is where we have been testing it.

I am also surprised others are not running into this issue. It happens as a result of the django compress script, so I wonder if most people are not running this? Seems like there should also be a test added for running this...

Matthias Runge (mrunge) wrote :

I'm running this: as checkout from github, installing dependencies via rpm (not using virtualenv or pip at all).
I haven't seen that issue.

Radomir Dopieralski (deshipu) wrote :

I reported the bug and made a pull request upstream. https://github.com/fusionbox/django-pyscss/pull/11

Fix proposed to branch: master
Review: https://review.openstack.org/111740

Changed in horizon:
assignee: Gregory Haynes (greghaynes) → Radomir Dopieralski (thesheep)

Reviewed: https://review.openstack.org/111740
Committed: https://git.openstack.org/cgit/openstack/horizon/commit/?id=be309f8db1be98efe4ade9016f9869996f2e4a05
Submitter: Jenkins
Branch: master

commit be309f8db1be98efe4ade9016f9869996f2e4a05
Author: Radomir Dopieralski <email address hidden>
Date: Mon Aug 4 16:13:58 2014 +0200

    Upgrade django-pyscss to version 1.0.2

    Change-Id: Ie57de8314df08f3353e65ba6a46f186d1d28af90
    Closes-bug: #1349774

Changed in horizon:
status: In Progress → Fix Committed
Derek Higgins (derekh) on 2014-08-11
Changed in tripleo:
status: Triaged → Fix Released
Akihiro Motoki (amotoki) on 2014-08-11
Changed in horizon:
milestone: none → juno-3
importance: Undecided → High

Change abandoned by Gregory Haynes (<email address hidden>) on branch: master
Review: https://review.openstack.org/110755

Thierry Carrez (ttx) on 2014-09-04
Changed in horizon:
status: Fix Committed → Fix Released

Change abandoned by Derek Higgins (<email address hidden>) on branch: master
Review: https://review.openstack.org/110258

Thierry Carrez (ttx) on 2014-10-16
Changed in horizon:
milestone: juno-3 → 2014.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers