testenv nodes DHCP br-untagged from two DHCP servers

Bug #1272803 reported by Robert Collins on 2014-01-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Derek Higgins

Bug Description

the undercloud network address on br-ctlplane is dhcp allocated, but when that bridge dhcps it gets the tripleo-bm-test ip not the undercloud address (or the other, randomly), leading to not being accessible from the undercloud control plane, and being unable to update metadata(or not contact the broker/jenkins slaves)

we might be able to add an alias with a custom MAC for this, or possibly just register the IP with a custom mac and apply it ourselves.

is critical because when these drop-off the network, all tests fail.

ALSO - any reboot of the nodes will randomly have them DHCP from the wrong server, with no PXE boot flags. SO they will fail to boot.

Dan Prince (dan-prince) wrote :

I think this all one big bug. Lets just go with 1272969.

summary: - testenv nodes will drop off network eventually
+ testenv nodes DHCP br-untagged from two DHCP servers
description: updated
description: updated
Robert Collins (lifeless) wrote :

(it's not one bug, because this isn't about incorrect ovs stuff this is about dhcping one interface from two servers :)

Robert Collins (lifeless) wrote :

One answer to this would be to kill dhclient after getting the network up. I kindof like this approach:)

description: updated
Derek Higgins (derekh) on 2014-03-18
Changed in tripleo:
assignee: nobody → Derek Higgins (derekh)
Derek Higgins (derekh) wrote :

Changing to high,
  fix in gerrit and not blocking anything, TE's can be rebuilt if if this causes a problem in any.

Changed in tripleo:
importance: Critical → High
Derek Higgins (derekh) wrote :

Test env images rebuilt ages ago, closing

Changed in tripleo:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers