[python-tripleoclient] overcloud deployment fails, but exits 0

Bug #1631177 reported by wes hayutin on 2016-10-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Adriano Petrich
tripleo-quickstart
Invalid
Undecided
Unassigned

Bug Description

As seen in
https://ci.centos.org/artifacts/rdo/jenkins-tripleo-quickstart-promote-newton-cloudsig-testing-minimal-7/undercloud/home/stack/overcloud_deploy.log.gz

The overcloud deployment fails however for what ever reason heat does not post a "CREATE_FAILED" statement that would trigger oooq to further debug the failure.

This can be fixed by adjusting the regex that detects the failure [1]

[1] https://github.com/redhat-openstack/ansible-role-tripleo-overcloud/blob/master/tasks/overcloud-status.yml#L14

John Trowbridge (trown) wrote :

This was originally filed as a tripleo-quickstart bug, but we should not need regex magic to detect a deployment failure. Instead the `openstack overcloud deploy` command should exit with non-zero exit code if it was not successful.

Changed in tripleo-quickstart:
status: New → Invalid
summary: - overcloud deployment fails, but oooq does not detect the failure
+ [python-tripleoclient] overcloud deployment fails, but exits 0
Changed in tripleo:
importance: Undecided → High
milestone: none → ocata-1
status: New → Triaged
Steven Hardy (shardy) on 2016-11-14
Changed in tripleo:
milestone: ocata-1 → ocata-2
tags: added: low-hanging-fruit
tags: added: tripleoclient
Changed in tripleo:
assignee: nobody → Adriano Petrich (apetrich)
Adriano Petrich (apetrich) wrote :

Is it still happening? I'm not able to reproduce it. If I change the overcloud-deploy script like this https://review.openstack.org/#/c/405614/2/roles/overcloud-deploy/templates/overcloud-deploy.sh.j2

2016-12-01 12:07:36Z [overcloud.ControllerNodesPostDeployment.ControllerArtifactsDeploy]: CREATE_FAILED CREATE aborted
2016-12-01 12:07:36Z [overcloud.ControllerNodesPostDeployment]: CREATE_FAILED Resource CREATE failed: Operation cancelled

 Stack overcloud CREATE_FAILED

Heat Stack create failed.
+ result=1
+ echo 1
1

wes hayutin (weshayutin) wrote :

OK.. thanks for checking that out.. If it is not recreating you can close this.
Thank you

Changed in tripleo:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers