Fail to create internalapi pacemaker resource agent

Bug #1748196 reported by Greg Charot on 2018-02-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo-ipsec
Critical
Juan Antonio Osorio Robles

Bug Description

When deploying the ansible playbook on Newton, the TASK [tripleo-ipsec : Add tripleo-ipsec-internalapi pacemaker resource agent] fails with the following error

fatal: [172.16.0.32]: FAILED! => {"changed": true, "cmd": ["pcs", "resource", "create", "tripleo-ipsec-internalapi", "ocf:heartbeat:ipsec", "tunnel=overcloud-internalapi-vip-tunnel", "vip=172.17.1.150", "--disabled"], "delta": "0:00:00.394856", "end": "2018-02-08 11:48:49.443079", "failed": true, "msg": "non-zero return code", "rc": 1, "start": "2018-02-08 11:48:49.048223", "stderr": "Error: Agent 'ocf:heartbeat:ipsec' is not installed or does not provide valid metadata: Metadata query for ocf:heartbeat:ipsec failed: -5, use --force to override", "stderr_lines": ["Error: Agent 'ocf:heartbeat:ipsec' is not installed or does not provide valid metadata: Metadata query for ocf:heartbeat:ipsec failed: -5, use --force to override"], "stdout": "", "stdout_lines": []}

fatal: [172.16.0.35]: FAILED! => {"changed": true, "cmd": ["pcs", "resource", "create", "tripleo-ipsec-internalapi", "ocf:heartbeat:ipsec", "tunnel=overcloud-internalapi-vip-tunnel", "vip=172.17.1.150", "--disabled"], "delta": "0:00:00.413819", "end": "2018-02-08 11:48:49.477938", "failed": true, "msg": "non-zero return code", "rc": 1, "start": "2018-02-08 11:48:49.064119", "stderr": "Error: Agent 'ocf:heartbeat:ipsec' is not installed or does not provide valid metadata: Metadata query for ocf:heartbeat:ipsec failed: -5, use --force to override", "stderr_lines": ["Error: Agent 'ocf:heartbeat:ipsec' is not installed or does not provide valid metadata: Metadata query for ocf:heartbeat:ipsec failed: -5, use --force to override"], "stdout": "", "stdout_lines": []}
fatal: [172.16.0.22]: FAILED! => {"changed": true, "cmd": ["pcs", "resource", "create", "tripleo-ipsec-internalapi", "ocf:heartbeat:ipsec", "tunnel=overcloud-internalapi-vip-tunnel", "vip=172.17.1.150", "--disabled"], "delta": "0:00:00.388529", "end": "2018-02-08 11:48:49.478202", "failed": true, "msg": "non-zero return code", "rc": 1, "start": "2018-02-08 11:48:49.089673", "stderr": "Error: Agent 'ocf:heartbeat:ipsec' is not installed or does not provide valid metadata: Metadata query for ocf:heartbeat:ipsec failed: -5, use --force to override", "stderr_lines": ["Error: Agent 'ocf:heartbeat:ipsec' is not installed or does not provide valid metadata: Metadata query for ocf:heartbeat:ipsec failed: -5, use --force to override"], "stdout": "", "stdout_lines": []}
fatal: [172.16.0.28]: FAILED! => {"changed": true, "cmd": ["pcs", "resource", "create", "tripleo-ipsec-internalapi", "ocf:heartbeat:ipsec", "tunnel=overcloud-internalapi-vip-tunnel", "vip=172.17.1.150", "--disabled"], "delta": "0:00:00.410690", "end": "2018-02-08 11:48:49.495642", "failed": true, "msg": "non-zero return code", "rc": 1, "start": "2018-02-08 11:48:49.084952", "stderr": "Error: Agent 'ocf:heartbeat:ipsec' is not installed or does not provide valid metadata: Metadata query for ocf:heartbeat:ipsec failed: -5, use --force to override", "stderr_lines": ["Error: Agent 'ocf:heartbeat:ipsec' is not installed or does not provide valid metadata: Metadata query for ocf:heartbeat:ipsec failed: -5, use --force to override"], "stdout": "", "stdout_lines": []}
changed: [172.16.0.29]

That task fails for the computes and ceph nodes on which the task should not be applied.

[stack@undercloud ~]$ nova list
+--------------------------------------+------------------+--------+------------+-------------+----------------------+
| ID | Name | Status | Task State | Power State | Networks |
+--------------------------------------+------------------+--------+------------+-------------+----------------------+
| 1f6e7003-b6ff-418b-89c7-65f571c4d085 | lab-ceph01 | ACTIVE | - | Running | ctlplane=172.16.0.22 |
| 38410d3d-a309-4a0c-b47d-a2245b8c3bc8 | lab-ceph02 | ACTIVE | - | Running | ctlplane=172.16.0.32 |
| c88ff0de-a7c7-4dec-9f89-78775b196393 | lab-ceph03 | ACTIVE | - | Running | ctlplane=172.16.0.35 |
| 4068dcd2-e589-49dd-a1f4-ee9329b9f819 | lab-compute01 | ACTIVE | - | Running | ctlplane=172.16.0.28 |
| 4599ec3f-821c-454f-9ca0-19511db4fd26 | lab-controller01 | ACTIVE | - | Running | ctlplane=172.16.0.26 |
| 80e2c1a0-1d11-4a8c-b76f-082bc3085a0d | lab-controller02 | ACTIVE | - | Running | ctlplane=172.16.0.23 |
| f6a3c813-b8b0-470f-bc07-9a7481646fe9 | lab-controller03 | ACTIVE | - | Running | ctlplane=172.16.0.29 |
+--------------------------------------+------------------+--------+------------+-------------+----------------------+

Revision history for this message
Juan Antonio Osorio Robles (juan-osorio-robles) wrote :
Changed in tripleo-ipsec:
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Juan Antonio Osorio Robles (juan-osorio-robles)
Changed in tripleo-ipsec:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tripleo-ipsec 8.0.2

This issue was fixed in the openstack/tripleo-ipsec 8.0.2 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers