tox --notest -elower-constraints-error

Bug #1853257 reported by baisen on 2019-11-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Tricircle
Undecided
Unassigned

Bug Description

File "/home/zuul/src/opendev.org/openstack/tricircle/.tox/lower-constraints/lib/python3.6/site-packages/pip/_vendor/pkg_resources/__init__.py", line 481, in get_distribution
    dist = get_provider(dist)
  File "/home/zuul/src/opendev.org/openstack/tricircle/.tox/lower-constraints/lib/python3.6/site-packages/pip/_vendor/pkg_resources/__init__.py", line 357, in get_provider
    return working_set.find(moduleOrReq) or require(str(moduleOrReq))[0]
  File "/home/zuul/src/opendev.org/openstack/tricircle/.tox/lower-constraints/lib/python3.6/site-packages/pip/_vendor/pkg_resources/__init__.py", line 900, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/home/zuul/src/opendev.org/openstack/tricircle/.tox/lower-constraints/lib/python3.6/site-packages/pip/_vendor/pkg_resources/__init__.py", line 791, in resolve
    raise VersionConflict(dist, req).with_context(dependent_req)
pip._vendor.pkg_resources.ContextualVersionConflict: (neutron-lib 1.25.0 (/home/zuul/src/opendev.org/openstack/tricircle/.tox/lower-constraints/lib/python3.6/site-packages), Requirement.parse('neutron-lib>=1.29.1'), {'neutron'})

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers