Inconsistency description

Bug #1571136 reported by Shinobu KINJO
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Tricircle
Fix Released
Medium
Prince Nana Owusu Boateng

Bug Description

This report is not about bug, but needs to be reported for visibility.

In the following files, "tricircle.common.exceptions" is imported as "t_exc".

./tricircle/api/controllers/pod.py
./tricircle/common/restapp.py
./tricircle/nova_apigw/controllers/aggregate.py

Rest of them, "tricircle.common.exceptions" is imported as "t_exceptions".
e.g.,

./tricircle/network/plugin.py

Since this project just started, we should fix out this kind of naming inconsistency.

Chaoyi Huang (joehuang)
Changed in tricircle:
importance: Undecided → Low
importance: Low → Medium
status: New → Confirmed
hejiawei (hjw)
Changed in tricircle:
assignee: nobody → hejiawei (hjw)
Revision history for this message
Prince Nana Owusu Boateng (nanaboat) wrote :

hejiawei do you have a patch on this on gerrit? I can take it up if you don't mind.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to tricircle (master)

Fix proposed to branch: master
Review: https://review.openstack.org/447644

Changed in tricircle:
assignee: hejiawei (hjw) → Prince Nana Owusu Boateng (nanaboat)
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to tricircle (master)

Reviewed: https://review.openstack.org/447644
Committed: https://git.openstack.org/cgit/openstack/tricircle/commit/?id=db09651b6b2d4b18ff51acfd7fdfe8a1ff6aa3e5
Submitter: Jenkins
Branch: master

commit db09651b6b2d4b18ff51acfd7fdfe8a1ff6aa3e5
Author: nanaboat <email address hidden>
Date: Mon Mar 20 18:31:48 2017 +0000

    Inconsistency Description

    1. What is the problem?
    This is not a bug fix but to attend naming inconstistency
    at this early stage of the project.

    2. What is the solution for the problem?
    To correct and maintain a consistent naming sequence for project.

    3. What features need to be implemented for Tricircle?
    None

    Change-Id: I84d6e2aa76f0e61f39f20cacf19fe6333d82aa1f
    Closes-Bug: #1571136

Changed in tricircle:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tricircle 3.2.0

This issue was fixed in the openstack/tricircle 3.2.0 release.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers