The Image Viewer for Translated Documentation Screenshots

Show English names instead of codes

Reported by David Planella on 2012-03-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
translated-documentation-screenshot-viewer
Medium
TLE

Bug Description

In the languages list, languages are shown as ISO codes. It would be much more readable to have them show as English names. I can think of two ways of achieving this:

- Using the iso-codes package
- Using the Launchpad API (i.e. language.english_name) [1]

[1] https://launchpad.net/+apidoc/devel.html#language

TLE (k-nielsen81) on 2012-03-02
Changed in translated-documentation-screenshot-viewer:
status: New → Confirmed
assignee: nobody → TLE (k-nielsen81)
status: Confirmed → In Progress
TLE (k-nielsen81) wrote :

Fixed in rev 19

Changed in translated-documentation-screenshot-viewer:
importance: Undecided → Medium
status: In Progress → Fix Committed

Al 02/03/12 11:38, En/na TLE ha escrit:
> Fixed in rev 19
>
> ** Changed in: translated-documentation-screenshot-viewer
> Importance: Undecided => Medium
>
> ** Changed in: translated-documentation-screenshot-viewer
> Status: In Progress => Fix Committed
>

Looks great, good work!

Just 2 things:

- The country names appear in lowercase for some reason [1]
- In the version of python-pyicu in Lucid, the module is not called
'icu', but 'PyICU'. You might want to have a check along the lines of
the pasted code below. We should probably have a similar check in
settings.py. Ah, the joys of maintaining code for several versions...

try:
   import icu
except ImportError:
   import PyICU

[1] http://176.34.113.223/ubuntudocs-devel/

--
David Planella
Ubuntu Translations Coordinator
www.ubuntu.com / www.davidplanella.wordpress.com
www.identi.ca/dplanella / www.twitter.com/dplanella

TLE (k-nielsen81) wrote :

The import issues is fixed in rev 21.

The lowercase issue I don't understand because I specifically ask python to capitalize those names because the are returned by the lib as all lowercase. Also, when I look at the page it looks ok.

Changed in translated-documentation-screenshot-viewer:
status: Fix Committed → In Progress
TLE (k-nielsen81) on 2012-03-10
Changed in translated-documentation-screenshot-viewer:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers