battery indicator does not change when plugged in

Bug #261953 reported by Jon Melamut on 2008-08-27
2
Affects Status Importance Assigned to Milestone
Transylvania
Low
Unassigned
Ubuntu Netbook Remix Launcher
High
Bill Filler

Bug Description

when you plug in a unit (Sylvania) the battery icon does not change. the popup changes to reflect it is running on AC, but the icon is still a battery

Bill Filler (bfiller) wrote :

pls try this again. I've tried it a bunch of times on multiple different hardware and the icon does change correctly when plugging/unplugging.

Changed in netbook-remix-launcher:
status: New → Invalid
Bill Filler (bfiller) wrote :

reproduced this finally on Sylvania unit. But it's very intermittent. The root problem is in gnome-power-manager gpm_cell_unit.c. When it is trying to figure out what icon to use, it doesn't take into account whether ac is plugged in or not. This is only a problem when the unit reports that is_discharging = TRUE and is_charging = FALSE even when AC is plugged in. This is what occurrs after some time on the Sylvania unit. I added a patch that takes into account whether ac is plugged in or not and tries to do the right thing by returning an icon name (either -charging or -charged) that will show the correct icon. Patch is attached.

Changed in netbook-remix-launcher:
assignee: nobody → bfiller
importance: Undecided → High
milestone: none → 1.0
status: Invalid → Fix Committed
Bill Filler (bfiller) wrote :
David Chen (david.chen) on 2008-10-07
Changed in trans:
status: New → Fix Committed
importance: Undecided → Low
Bill Filler (bfiller) on 2009-01-27
Changed in netbook-remix-launcher:
status: Fix Committed → Fix Released
jithukseb (jithukseb) wrote :

what is this

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers