Test failure with bzr 2.6 and trac 1.0

Bug #1208025 reported by Andrew Starr-Bochicchio on 2013-08-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Trac-Bzr
Undecided
Unassigned

Bug Description

This is with trac-bzr trunk and the patch from lp:~jteh/trac-bzr/newDeps

$ PYTHONPATH=. nosetests tracbzr
..........F........
======================================================================
FAIL: tracbzr.tests.test_repository.TestRepository.test_next_rev
----------------------------------------------------------------------
_StringException: log: {{{
16.886 creating repository in file:///tmp/testbzr-TJ194w.tmp/tracbzr.tests.test_repository.TestRepository.test_next_rev/work/repo/.bzr/.
16.892 creating repository in file:///tmp/testbzr-TJ194w.tmp/tracbzr.tests.test_repository.TestRepository.test_next_rev/work/repo/tree/.bzr/.
16.893 creating branch <bzrlib.branch.BzrBranchFormat7 object at 0x24b74d0> in file:///tmp/testbzr-TJ194w.tmp/tracbzr.tests.test_repository.TestRepository.test_next_rev/work/repo/tree/
16.898 trying to create missing lock '/tmp/testbzr-TJ194w.tmp/tracbzr.tests.test_repository.TestRepository.test_next_rev/work/repo/tree/.bzr/checkout/dirstate'
16.940 opening working tree '/tmp/testbzr-TJ194w.tmp/tracbzr.tests.test_repository.TestRepository.test_next_rev/work/repo/tree'
17.006 opening working tree '/tmp/testbzr-TJ194w.tmp/tracbzr.tests.test_repository.TestRepository.test_next_rev/work/repo/tree'
17.058 preparing to commit
    INFO Committing to: /tmp/testbzr-TJ194w.tmp/tracbzr.tests.test_repository.TestRepository.test_next_rev/work/repo/tree/
17.060 Selecting files for commit with filter None
    INFO added a
    INFO added a/b
    INFO Committed revision 1.
17.349 Committed revid foo%bar as revno 1.
17.407 opening working tree '/tmp/testbzr-TJ194w.tmp/tracbzr.tests.test_repository.TestRepository.test_next_rev/work/repo/tree'
17.417 creating repository in file:///tmp/testbzr-TJ194w.tmp/tracbzr.tests.test_repository.TestRepository.test_next_rev/work/repo/other/.bzr/.
17.419 Using fetch logic to copy between CHKInventoryRepository('file:///tmp/testbzr-TJ194w.tmp/tracbzr.tests.test_repository.TestRepository.test_next_rev/work/repo/tree/.bzr/repository/')(RepositoryFormat2a()) and CHKInventoryRepository('file:///tmp/testbzr-TJ194w.tmp/tracbzr.tests.test_repository.TestRepository.test_next_rev/work/repo/other/.bzr/repository/')(RepositoryFormat2a())
17.419 fetching: <PendingAncestryResult heads:frozenset(['foo%bar']) repo:CHKInventoryRepository('file:///tmp/testbzr-TJ194w.tmp/tracbzr.tests.test_repository.TestRepository.test_next_rev/work/repo/tree/.bzr/repository/')>
17.693 creating branch <bzrlib.branch.BzrBranchFormat7 object at 0x354b690> in file:///tmp/testbzr-TJ194w.tmp/tracbzr.tests.test_repository.TestRepository.test_next_rev/work/repo/other/
17.703 created new branch BzrBranch7(file:///tmp/testbzr-TJ194w.tmp/tracbzr.tests.test_repository.TestRepository.test_next_rev/work/repo/other/)
17.706 trying to create missing lock '/tmp/testbzr-TJ194w.tmp/tracbzr.tests.test_repository.TestRepository.test_next_rev/work/repo/other/.bzr/checkout/dirstate'
17.779 opening working tree '/tmp/testbzr-TJ194w.tmp/tracbzr.tests.test_repository.TestRepository.test_next_rev/work/repo/other'
17.992 opening working tree '/tmp/testbzr-TJ194w.tmp/tracbzr.tests.test_repository.TestRepository.test_next_rev/work/repo/other'
18.054 preparing to commit
    INFO Committing to: /tmp/testbzr-TJ194w.tmp/tracbzr.tests.test_repository.TestRepository.test_next_rev/work/repo/other/
18.056 Selecting files for commit with filter None
    INFO modified a/b
    INFO added a/c
    INFO Committed revision 2.
18.332 Committed revid baz as revno 2.
18.403 Using fetch logic to copy between CHKInventoryRepository('file:///tmp/testbzr-TJ194w.tmp/tracbzr.tests.test_repository.TestRepository.test_next_rev/work/repo/other/.bzr/repository/')(RepositoryFormat2a()) and CHKInventoryRepository('file:///tmp/testbzr-TJ194w.tmp/tracbzr.tests.test_repository.TestRepository.test_next_rev/work/repo/tree/.bzr/repository/')(RepositoryFormat2a())
18.403 fetching: <SearchResult search:(set(['baz']), set(['null:', 'foo%bar']), 1)>
18.690 Base revid: 'foo%bar'
    INFO All changes applied successfully.
18.769 preparing to commit
    INFO Committing to: /tmp/testbzr-TJ194w.tmp/tracbzr.tests.test_repository.TestRepository.test_next_rev/work/repo/tree/
18.773 Selecting files for commit with filter None
    INFO modified a/b
    INFO added a/c
    INFO Committed revision 2.
19.049 Committed revid qux as revno 2.
}}}

Traceback (most recent call last):
  File "/tmp/buildd/trac-bzr-0.4.2+bzr129/tracbzr/tests/test_repository.py", line 140, in test_next_rev
    self.assertEqual('tree,2', repo.next_rev('tree,1', 'tree'))
  File "/usr/lib/python2.7/dist-packages/bzrlib/tests/__init__.py", line 1360, in assertEqual
    pprint.pformat(a), pprint.pformat(b)))
AssertionError: not equal:
a = 'tree,2'
b = None

-------------------- >> begin captured logging << --------------------
bzr: INFO: Committing to: /tmp/testbzr-TJ194w.tmp/tracbzr.tests.test_repository.TestRepository.test_next_rev/work/repo/tree/
bzr: INFO: added a
bzr: INFO: added a/b
bzr: INFO: Committed revision 1.
bzr: INFO: Committing to: /tmp/testbzr-TJ194w.tmp/tracbzr.tests.test_repository.TestRepository.test_next_rev/work/repo/other/
bzr: INFO: modified a/b
bzr: INFO: added a/c
bzr: INFO: Committed revision 2.
bzr: INFO: All changes applied successfully.
bzr: INFO: Committing to: /tmp/testbzr-TJ194w.tmp/tracbzr.tests.test_repository.TestRepository.test_next_rev/work/repo/tree/
bzr: INFO: modified a/b
bzr: INFO: added a/c
bzr: INFO: Committed revision 2.
--------------------- >> end captured logging << ---------------------

----------------------------------------------------------------------
Ran 19 tests in 26.384s

FAILED (failures=1)

Richard Wilbur (richard-wilbur) wrote :

Andrew, is this problem still present in trunk lp:trac-bzr code? I just merged treaves code to fix lp:1165948 "Update for bzr 2.6".

Changed in trac-bzr:
status: New → Invalid
Richard Wilbur (richard-wilbur) wrote :

I haven't yet tested trac-bzr myself, but after I merged the branch which I mentioned in my previous comment the build system showed test failures which included calls of deprecated methods as well as this test failure. Unfortunately it looks like this one is still with us.

Changed in trac-bzr:
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers