tpfand doesn't work without HAL

Reported by vava on 2010-05-04
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
tp-fan
Undecided
Unassigned

Bug Description

As Ubuntu 10.04 does not depend on HAL anymore and I'm pretty sure it is removed from installation packages, tpfand has to be able to work without it. It doesn't now, python says it can't concatenate string with None.

I've tried to make it call to DeviceKit to get vendor and such information from there instead, but seems like DeviceKit just don't have any devices similar to 'computer' one.

So, I just replaced None with empty strings and that works. It won't show the proper laptop model but that is better than crashing. Patch is attached.

BTW would be good if package said it did depend on HAL.

vava (vadim-atlygin) wrote :
description: updated
Martin Emrich (emme) wrote :

Thanks for the patch! I hard-coded the specs for my X200 into the source, now it works again. I got them from calling "sudo lshw", so whatever lshw does, it could be incorporated into tpfand by someone actually speaking python :)

Simon Legner (simon04) wrote :

The attached patch removes the HAL dependency and uses `lshw` instead to determine vendor, model and id of the system.
I'd love to see the HAL dependency dropped in the next release.

vl-sht (vl-sht) wrote :

Unfortunately, in Ubuntu 11.04 "lshw -class system" won't report Model and Manufacturer, so that Simon's patch fails. Here is a patch for using dmidecode module instead of lshw. You'll need to install "python-dmidecode" manually. Please report if this patch works for you.

Fup Duck (duckdalbe) wrote :

Here's a patch slightly different from the one of vl-sht: <https://gist.github.com/3125216>.

It uses the same data but grabs it from /sys, so python-dmidecode is not needed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers