touchpad-indicator preference window don't open

Reported by vladimiro on 2011-11-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Touchpad-indicator
Medium
Lorenzo Carbonell

Bug Description

touchpad-indicator work in kde 4.7, but I can't set preferences, because don't start preference's window. Kubuntu 11.10 32bit.
I can set unable or disable touchpad manually after ever system restart, but I can't set disable touchpad when mouse insert, because preference window don't open.

Please, can you run touchpad-indicator in terminal and open preferece's window, in order to see what's the bug?

Thanks

I don't use Kubuntu, and I can't see

:~$ touchpad-indicator
#####################################################
No LSB modules are available.
#####################################################
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
Version: i686
#####################################################

Touchpad-Indicator version: 0.9.1.2
#####################################################
apps.indicators.touchpad-indicator
Xlib.protocol.request.QueryExtension
Xlib.protocol.request.QueryExtension
apps.indicators.touchpad-indicator
Traceback (most recent call last):
  File "/usr/share/touchpad-indicator/touchpad-indicator.py", line 360, in
on_preferences_item
    preferences_dialog = PreferencesDialog()
  File "/usr/share/touchpad-indicator/preferences_dialog.py", line 50, in
__init__
    self.set_icon_from_file(com.ICON)
  File "/usr/lib/python2.7/dist-packages/gi/types.py", line 43, in function
    return info.invoke(*args, **kwargs)
gi._glib.GError: Couldn't recognize the image file format for file
'/usr/share/pixmaps/touchpad-indicator.svg'

:-)

2011/11/10 Lorenzo Carbonell <email address hidden>

> Please, can you run touchpad-indicator in terminal and open preferece's
> window, in order to see what's the bug?
>
> Thanks
>
> I don't use Kubuntu, and I can't see
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/887072
>
> Title:
> touchpad-indicator preference window don't open
>
> Status in Touchpad-indicator:
> New
>
> Bug description:
> touchpad-indicator work in kde 4.7, but I can't set preferences, because
> don't start preference's window. Kubuntu 11.10 32bit.
> I can set unable or disable touchpad manually after ever system restart,
> but I can't set disable touchpad when mouse insert, because preference
> window don't open.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/touchpad-indicator/+bug/887072/+subscriptions
>

Gregg (gwiecek) wrote :

Confirm.
The same here.

EV (ebaykembel) wrote :

It's not a bug. You should install python-rsvg and probably librsvg2.

Changed in touchpad-indicator:
assignee: nobody → Lorenzo Carbonell (lorenzo-carbonell)
status: New → In Progress
milestone: none → 0.9.3.0
status: In Progress → Fix Committed
Changed in touchpad-indicator:
importance: Undecided → Medium
Changed in touchpad-indicator:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers