Touchpad-indicator incorrectly detects some devices as a mouse.

Bug #804372 reported by Miguel Ángel Santamaría Rogado on 2011-07-01
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Lorenzo Carbonell

Bug Description

In some laptops, there is some hardware incorrectly detected as a mouse (Acer TimelineX, Lenovo/IBM thinkpad and maybe others). This causes that the indicator does not disable the touchpad.

If you are bitten by this bug, please download the attached script in /usr/share/touchpad-indicator and send us the output. The output can be very long, so better direct it to a file and attach it; you can do that executing this in a terminal: /usr/share/touchpad-indicator/ > my_device_list

Regards, Miguel Angel.

UPDATE: Since version 0.8.1 is included with Touchpad-indicator.

Changed in touchpad-indicator:
status: New → In Progress
assignee: nobody → Miguel Angel Santamaría Rogado (gabiel)
Stan Angeloff (stanangeloff) wrote :

This actually happens on my Dell Inspiron N5110. When I have the panel auto-start and auto-disable the mouse, on reboot the touchpad is always disabled. Once I plug in a mouse and unplug it, I can use it again. Very annoying as I don't always bring a mouse with me and end up locking myself out of half the stuff on the PC.

Attached is the report as generated by Happy to carry any more testing required.

Stan Angeloff (stanangeloff) wrote :

Typical, I posted in the wrong bug -- should have went in here

Hello Stan,

check the attached, it must work now. Just overwrite the existing /usr/share/touchpad-indicator/ and launch the indicator.

Regards, Miguel Angel.

description: updated
description: updated
Stan Angeloff (stanangeloff) wrote :

Hi Miguel,

Thank you for the provided update. I suffered a Kernel Panic and wasn't able to test earlier. I can confirm my trackpad is recognised on boot now.

JPM (jpm-5) wrote :
  • a Edit (21.1 KiB, text/plain)

Ubuntu 11.04 ; Dell Latitude E6320

When I lauch touchpad-indicator (8.1.1) I notice no change.

I join the output of device_list

Hello JPM,

have you changed You have to use the attached one ( until it gets included in a new release.

Regards, Miguel Angel.

JPM (jpm-5) wrote :

Hello Miguel Angel,

Well, indeed, now it works. I am ashamed !

Thanks a lot,

harry (rimez) wrote :

hi miguel,

Any news on this bug? I'm really wanting this indicator :(

Changed in touchpad-indicator:
status: In Progress → Fix Committed
milestone: none →
importance: Undecided → High

Hello Harry,

try the latest version. If your your touchpad is still detected as a mouse send the output of

Regards, Miguel Angel.

harry (rimez) wrote :

Hi Miguel,

Still not working for me.
output of the script attached.


Changed in touchpad-indicator:
status: Fix Committed → In Progress


run touchpad-indicator -l > devices_list.txt

and paste here

Thanks for your patient, I think we can solve this soon

Changing the did not work for me.

xinput set-int-prop "PS/2 Mouse" "Device Enabled" 8 0
correctly disable my touchpad.
This is the only way I found.

It is that : Ubunti see my touchpad as a mouse ?

Ivan Dokov (ivandokov) wrote :

$ ./ > ~/output
No LSB modules are available.
Traceback (most recent call last):
  File "./", line 101, in <module>
UnicodeDecodeError: 'ascii' codec can't decode byte 0xff in position 0: ordinal not in range(128)

This is what I've got. Using Ubuntu 11.10 with Sony Vaio VPCEB1S1E

Ivan Dokov (ivandokov) wrote :

Sorry for the double post. Forgot to attach the output from touchpad-indicator -l

harry (rimez) wrote :

After reinstalling Natty (botched attempt at moving to Oneiric Unity/Gnome3) I was reconfiguring my system. Whilst looking up the imps mouse fix I found a post on the Ubuntu forums which referred to a synaptic bug with a patched driver.

With the patched driver the touchpad indicator finally works (on my TimelineX 3820tg)!

Here's the bug:
Here's the link to the driver:

I hope it helps someone else :)

harry (rimez) wrote :

Update to my last one -- there a newer driver that I didn't catch the first time around:

It appears that this will be put into the 3.3 kernel.

Changed in touchpad-indicator:
milestone: → none
milestone: none →
assignee: Miguel Angel Santamaría Rogado (gabiel) → Lorenzo Carbonell (lorenzo-carbonell)
status: In Progress → Fix Committed
Changed in touchpad-indicator:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers