Audio playback does not work until after recv first phone call [Galaxy Nexus]

Bug #1217072 reported by Bill Filler on 2013-08-26
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
touch-preview-images
Fix Released
High
David Henningsson

Bug Description

Maguro
pulseaudio build 20130826

Audio playback does not work in the media player or ringtone until after one incoming call comes into the phone.

Steps to reproduce:
1) reboot phone
2) go to video lens
3) play Tears of Steel
4) video playback starts (but drops frames, will file separate bug) but no audio is played back (BUG)
5) call the phone from another phone
6) ubuntu touch phone should play ringtone, but doesn't (BUG)
7) hang up from the calling side before answering the call.

Now
8) kill media player app and relaunch Tears of Steel
9) notice that sounds starts to play
10) call phone again from another phone and ringtone starts ringing as it should

Bill Filler (bfiller) on 2013-08-26
Changed in touch-preview-images:
assignee: nobody → David Henningsson (diwic)
Bill Filler (bfiller) wrote :

per email I tried this:
>>To try to nail this one down (Maguro specific, so I can't reproduce it
>>here), can we determine what causes the audio to start working here? E
>>g, if you playback a simple sound before the first ringtone ( paplay
>>/usr/share/sounds/alsa/Front_Left.wav ), does the sound play, and
>>secondly, does it make the ringtone work?

playing the sound with paplay does not cuase the sound to play and does not make the ringtone work

Bill Filler (bfiller) wrote :

>>Also, does the ringtone on the 2nd call start working regardless of
>>whether you answer the first call or not?

yes

summary: - Audio playback does not work until after recv first phone call
+ Audio playback does not work until after recv first phone call [Galaxy
+ Nexus]
David Henningsson (diwic) wrote :

Please install the pulseaudio-utils package, then try the following (while the phone is in the faulty state) :

pactl set-sink-port @DEFAULT_SINK@ "[Out] Earpiece"

Is sound now working? If not, continue with:

pactl set-sink-port @DEFAULT_SINK@ "[Out] Speaker"

Is sound now working?

David Henningsson (diwic) wrote :

If the above does not work, let's try gathering some more logs:

While the first ringtone is playing (the non-working one), please execute these commands: "pacmd list" and "amixer -D hw:Tuna contents". Save their output and attach to this bug.

Then, while the second ringtone is playing (the working one), redo the same - execute "pacmd list" and "amixer -D hw:Tuna contents". Save their output and attach to this bug.

Thanks.

Changed in touch-preview-images:
status: New → Incomplete
importance: Undecided → High
David Henningsson (diwic) wrote :

1.0.27.2-1ubuntu3 of alsa-lib has updated UCM files for Maguro. Can you retest with that version and see if it is still a problem?

Ricardo Salveti (rsalveti) wrote :

This should be fixed with the original image already (build >= 29).

David Henningsson (diwic) wrote :

I think this is fixed since a while back. Feel free to reopen if it isn't.

Changed in touch-preview-images:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers