Cancel network connect on password request crashes shell

Bug #1180511 reported by Sergio Schvezov on 2013-05-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
touch-preview-images
Fix Released
Medium
Nick Dedekind
qtdeclarative-opensource-src (Ubuntu)
Undecided
Timo Jyrinki

Bug Description

HARDWARE=maguro
JENKINS_BUILD=123

Steps to reproduce:
- Go to network indicator
- Disconnect from know network (one that's already setup).
- Attempt to connect to new network.
- On password request, Cancel.
- Rinse and repeat.

Expected result:
- Infinite loop of cancel and select

Actual result:
- Shell crash

Most likely cause seems to be that the network I previously setup starts to autoconnect when I Cancel the password request on the previous one.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1180511

tags: added: iso-testing
Albert Astals Cid (aacid) wrote :

Happens on my Nexus4 too

Changed in touch-preview-images:
status: New → Confirmed
Albert Astals Cid (aacid) wrote :

The backtrace

#0 0x4009de4c in data (this=0x4) at /usr/include/qt5/QtCore/qscopedpointer.h:134
#1 qGetPtrHelper<QScopedPointer<QObjectData> > (p=...) at /usr/include/qt5/QtCore/qglobal.h:991
#2 d_func (this=0x0) at ../../include/QtQml/5.0.2/QtQml/private/../../../../../src/qml/qml/qqmlengine.h:155
#3 get (e=0x0) at ../../include/QtQml/5.0.2/QtQml/private/../../../../../src/qml/qml/qqmlengine_p.h:491
#4 QQmlVME::execute (this=this@entry=0x3632d20, errors=errors@entry=0x3632cf8, interrupt=...) at qml/qqmlvme.cpp:193
#5 0x40095918 in QQmlIncubatorPrivate::incubate (this=0x3632cd8, i=...) at qml/qqmlincubator.cpp:287
#6 0x40095d80 in QQmlIncubationController::incubateFor (this=0x60888, msecs=<optimized out>) at qml/qqmlincubator.cpp:379
#7 0x40705346 in QMetaCallEvent::placeMetaCall(QObject*) () from /usr/lib/arm-linux-gnueabihf/libQt5Core.so.5
#8 0x40707160 in QObject::event(QEvent*) () from /usr/lib/arm-linux-gnueabihf/libQt5Core.so.5
#9 0x406edf4a in QCoreApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/arm-linux-gnueabihf/libQt5Core.so.5
#10 0x406edf7c in QCoreApplication::notify(QObject*, QEvent*) () from /usr/lib/arm-linux-gnueabihf/libQt5Core.so.5
#11 0x406edd5a in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/arm-linux-gnueabihf/libQt5Core.so.5
#12 0x406ef392 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/arm-linux-gnueabihf/libQt5Core.so.5
#13 0x4071d218 in ?? () from /usr/lib/arm-linux-gnueabihf/libQt5Core.so.5
#14 0x410965c8 in g_main_context_dispatch () from /lib/arm-linux-gnueabihf/libglib-2.0.so.0
#15 0x41096812 in ?? () from /lib/arm-linux-gnueabihf/libglib-2.0.so.0
#16 0x41096812 in ?? () from /lib/arm-linux-gnueabihf/libglib-2.0.so.0
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Timo Jyrinki (timo-jyrinki) wrote :

Testable now also for raring (previously saucy) at ppa:canonical-qt5-edgers/qt5-beta-proper

I'd like to have two independent confirmations about the problem being fixed and no regressions (I can combine with bug #1176962 feedback) before doing a PPA copy.

1. apt-add-repository ppa:canonical-qt5-edgers/qt5-beta-proper
2. apt-get update
3. apt-get dist-upgrade
4. poweroff
5. start again, test

Albert Astals Cid (aacid) wrote :

Seems i can't reproduce the crash anymore (I can reproduce various items being marked as connected, but that'd be a bug for the wireless indicator guys)

Albert Astals Cid (aacid) wrote :

when using the new pacakges with the patches, that's it

Changed in touch-preview-images:
milestone: none → ubuntu-13.05
Michał Sawicz (saviq) on 2013-05-21
Changed in touch-preview-images:
assignee: Albert Astals Cid (aacid) → Nick Dedekind (nick-dedekind)
Timo Jyrinki (timo-jyrinki) wrote :

Thanks for Michal's testing, copied to daily-build-next from which it will be picked up to the images.

Changed in touch-preview-images:
status: Confirmed → Fix Released
Changed in qtdeclarative-opensource-src (Ubuntu):
status: New → Fix Released
assignee: nobody → Timo Jyrinki (timo-jyrinki)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers