Searching for people/music/video restarts the shell on manta

Bug #1170550 reported by Sergio Schvezov on 2013-04-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
touch-preview-images
Fix Released
Critical
Albert Astals Cid

Bug Description

Hardware manta
Jenkins build 84
Image 20130418

Steps to reproduce:
http://www.youtube.com/watch?v=W1E-EYBcf7E
(you may notice the media player in the background, I can confirm it still happens after a fresh reboot).

logcat output:
I/ ( 1113): virtual void android::SessionService::report_osk_visible(int32_t, int32_t, int32_t, int32_t)
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::report_osk_visible(int32_t, int32_t, int32_t, int32_t)(x=0, y=932, width=2560, height=668)
I/ubuntu::detail::ApplicationManager( 132): virtual bool android::InputSetup::DummyApplication::updateInfo()
I/ubuntu::detail::ApplicationManager( 132): virtual bool android::InputSetup::DummyApplicationWindow::updateInfo()
I/ubuntu::detail::ApplicationManager( 132): pid_t ubuntu::detail::pid_to_vpid(int)(1113)
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::start_a_new_session(int32_t, int32_t, const android::String8&, const android::String8&, const android::sp<android::IApplicationManagerSession>&, int): Invoked for system_session_type
I/ubuntu::detail::ApplicationManager( 132): Registering input channel as observer: true
I/ ( 1113): virtual android::IApplicationManagerSession::SurfaceProperties android::Session::ApplicationManagerSession::query_surface_properties_for_token(int32_t): 1
I/ubuntu::detail::ApplicationManager( 132): virtual bool ubuntu::detail::ApplicationSession::InputWindowHandle::updateInfo(): touchable_region = (0, 0, 2559, 789)
I/ubuntu::detail::ApplicationManager( 132): New surface for system session, adjusting layer now.
I/ ( 1113): Enter virtual void android::Session::ApplicationManagerSession::raise_surface_to_layer(int32_t, int) (823): 1, 1000007
I/ ( 1113): Found surface for token: 1
I/ ( 1113): Leave virtual void android::Session::ApplicationManagerSession::raise_surface_to_layer(int32_t, int) (823): 1, 1000007
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::request_update_for_session(const android::sp<android::IApplicationManagerSession>&)
E/Trace ( 1113): error opening trace file: No such file or directory (2)
D/mali_winsys( 1113): new_window_surface returns 0x3000
I/ubuntu::detail::ApplicationManager( 132): virtual int ubuntu::detail::ApplicationManager::get_session_pid(const android::sp<android::IApplicationManagerSession>&)
I/ ( 1113): virtual void android::UbuntuSurface::set_visible(int, bool): true
I/ ( 1113): surface_control->show(INT_MAX): 0 id=823
I/ubuntu::detail::ApplicationManager( 132): Lowering current application now for idx: 0
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():363
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():369 -- remote_pid=849 desktop_file=/usr/share/applications/shotwell.desktop
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():375
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():381
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():385
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():389
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():393
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():397
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():403
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():405
I/ubuntu::detail::ApplicationManager( 132): virtual int ubuntu::detail::ApplicationManager::get_session_pid(const android::sp<android::IApplicationManagerSession>&)
I/ ( 1113): virtual void android::UbuntuSurface::set_visible(int, bool): false
I/ ( 1113): surface_control->hide(): 0
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():363
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():369 -- remote_pid=823 desktop_file=/usr/share/applications/shotwell.desktop
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():375
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():381
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():385
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():389
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():393
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():397
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():403
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():405
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():363
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():369 -- remote_pid=926 desktop_file=/usr/share/applications/shotwell.desktop
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():375
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():381
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():385
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():389
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():393
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():397
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():403
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::binderDied(const android::wp<android::IBinder>&)():405
E/linker ( 1440): ics/linker.c:1598| WARNING: Skipping libc.so
D/libEGL ( 1440): loaded /vendor/lib/egl/libGLES_mali.so
I/ ( 1440): virtual void android::SessionService::report_osk_invisible()
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::report_osk_invisible()
I/ubuntu::detail::ApplicationManager( 132): virtual bool android::InputSetup::DummyApplication::updateInfo()
I/ubuntu::detail::ApplicationManager( 132): virtual bool android::InputSetup::DummyApplicationWindow::updateInfo()
E/linker ( 1467): ics/linker.c:1598| WARNING: Skipping libc.so
D/libEGL ( 1467): loaded /vendor/lib/egl/libGLES_mali.so
E/linker ( 1547): ics/linker.c:1598| WARNING: Skipping libc.so
I/ubuntu::detail::ApplicationManager( 132): pid_t ubuntu::detail::pid_to_vpid(int)(1547)
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::start_a_new_session(int32_t, int32_t, const android::String8&, const android::String8&, const android::sp<android::IApplicationManagerSession>&, int): Invoked for system_session_type
D/libEGL ( 1547): loaded /vendor/lib/egl/libGLES_mali.so
I/ubuntu::detail::ApplicationManager( 132): Registering input channel as observer: true
I/ ( 1547): virtual android::IApplicationManagerSession::SurfaceProperties android::Session::ApplicationManagerSession::query_surface_properties_for_token(int32_t): 1
I/ubuntu::detail::ApplicationManager( 132): virtual bool ubuntu::detail::ApplicationSession::InputWindowHandle::updateInfo(): touchable_region = (0, 0, 799, 599)
I/ubuntu::detail::ApplicationManager( 132): New surface for system session, adjusting layer now.
I/ ( 1547): Enter virtual void android::Session::ApplicationManagerSession::raise_surface_to_layer(int32_t, int) (1250): 1, 1000003
I/ ( 1547): Found surface for token: 1
I/ ( 1547): Leave virtual void android::Session::ApplicationManagerSession::raise_surface_to_layer(int32_t, int) (1250): 1, 1000003
E/Trace ( 1547): error opening trace file: No such file or directory (2)
D/mali_winsys( 1547): new_window_surface returns 0x3000
I/ubuntu::detail::ApplicationManager( 132): virtual int ubuntu::detail::ApplicationManager::get_session_pid(const android::sp<android::IApplicationManagerSession>&)
I/ ( 1547): virtual void android::UbuntuSurface::set_visible(int, bool): false
I/ ( 1547): surface_control->hide(): 0
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::request_update_for_session(const android::sp<android::IApplicationManagerSession>&)
E/linker ( 1563): ics/linker.c:1598| WARNING: Skipping libc.so
I/ ( 1467): virtual void android::SessionService::unfocus_running_sessions()
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::unfocus_running_sessions()
I/ ( 1467): virtual int32_t android::SessionService::set_surface_trap(int32_t, int32_t, int32_t, int32_t)
I/ubuntu::detail::ApplicationManager( 132): virtual bool android::InputSetup::DummyApplication::updateInfo()
I/ubuntu::detail::ApplicationManager( 132): virtual bool android::InputSetup::DummyApplicationWindow::updateInfo()
I/ ( 1467): virtual int32_t android::SessionService::set_surface_trap(int32_t, int32_t, int32_t, int32_t)
I/ubuntu::detail::ApplicationManager( 132): virtual bool android::InputSetup::DummyApplication::updateInfo()
I/ubuntu::detail::ApplicationManager( 132): virtual bool android::InputSetup::DummyApplicationWindow::updateInfo()
I/ubuntu::detail::ApplicationManager( 132): pid_t ubuntu::detail::pid_to_vpid(int)(1467)
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::start_a_new_session(int32_t, int32_t, const android::String8&, const android::String8&, const android::sp<android::IApplicationManagerSession>&, int): Invoked for system_session_type
I/ubuntu::detail::ApplicationManager( 132): Registering input channel as observer: true
I/ ( 1467): virtual android::IApplicationManagerSession::SurfaceProperties android::Session::ApplicationManagerSession::query_surface_properties_for_token(int32_t): 1
I/ubuntu::detail::ApplicationManager( 132): virtual bool ubuntu::detail::ApplicationSession::InputWindowHandle::updateInfo(): touchable_region = (0, 0, 2559, 1599)
I/ubuntu::detail::ApplicationManager( 132): New surface for system session, adjusting layer now.
I/ ( 1467): Enter virtual void android::Session::ApplicationManagerSession::raise_surface_to_layer(int32_t, int) (1171): 1, 1000002
I/ ( 1467): Found surface for token: 1
I/ ( 1467): Leave virtual void android::Session::ApplicationManagerSession::raise_surface_to_layer(int32_t, int) (1171): 1, 1000002
E/Trace ( 1467): error opening trace file: No such file or directory (2)
D/mali_winsys( 1467): new_window_surface returns 0x3000
I/ubuntu::detail::ApplicationManager( 132): virtual void ubuntu::detail::ApplicationManager::request_fullscreen(const android::sp<android::IApplicationManagerSession>&)
I/ubuntu::detail::ApplicationManager( 132): virtual int ubuntu::detail::ApplicationManager::get_session_pid(const android::sp<android::IApplicationManagerSession>&)
I/ ( 1467): virtual void android::UbuntuSurface::set_visible(int, bool): true
I/ ( 1467): surface_control->show(INT_MAX): 0 id=1171
I/ubuntu::detail::ApplicationManager( 132): Lowering current application now for idx: 0
I/ ( 1467): virtual void android::SessionService::unset_surface_trap(int32_t)(12)
I/ubuntu::detail::ApplicationManager( 132): virtual bool android::InputSetup::DummyApplication::updateInfo()
I/ubuntu::detail::ApplicationManager( 132): virtual bool android::InputSetup::DummyApplicationWindow::updateInfo()
I/ ( 1467): virtual int32_t android::SessionService::set_surface_trap(int32_t, int32_t, int32_t, int32_t)
I/ubuntu::detail::ApplicationManager( 132): virtual bool android::InputSetup::DummyApplication::updateInfo()
I/ubuntu::detail::ApplicationManager( 132): virtual bool android::InputSetup::DummyApplicationWindow::updateInfo()
I/ ( 1467): virtual void android::SessionService::unset_surface_trap(int32_t)(14)
I/ubuntu::detail::ApplicationManager( 132): virtual bool android::InputSetup::DummyApplication::updateInfo()
I/ubuntu::detail::ApplicationManager( 132): virtual bool android::InputSetup::DummyApplicationWindow::updateInfo()
I/ ( 1467): virtual int32_t android::SessionService::set_surface_trap(int32_t, int32_t, int32_t, int32_t)
I/ubuntu::detail::ApplicationManager( 132): virtual bool android::InputSetup::DummyApplication::updateInfo()
I/ubuntu::detail::ApplicationManager( 132): virtual bool android::InputSetup::DummyApplicationWindow::updateInfo()
I/ ( 1467): virtual void android::SessionService::unset_surface_trap(int32_t)(13)
I/ubuntu::detail::ApplicationManager( 132): virtual bool android::InputSetup::DummyApplication::updateInfo()
I/ubuntu::detail::ApplicationManager( 132): virtual bool android::InputSetup::DummyApplicationWindow::updateInfo()
I/ ( 1467): virtual int32_t android::SessionService::set_surface_trap(int32_t, int32_t, int32_t, int32_t)
I/ubuntu::detail::ApplicationManager( 132): virtual bool android::InputSetup::DummyApplication::updateInfo()
I/ubuntu::detail::ApplicationManager( 132): virtual bool android::InputSetup::DummyApplicationWindow::updateInfo()

description: updated
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1170550

tags: added: iso-testing
Ricardo Salveti (rsalveti) wrote :

Confirming, able to reproduce after opening a video and doing a lens search.

Changed in touch-preview-images:
importance: Undecided → Critical
status: New → Confirmed
Albert Astals Cid (aacid) wrote :

Yes, this is unfortunate and basically is a Qt bug https://bugreports.qt-project.org/browse/QTBUG-30632 contains a very simple way to reproduce it

Note that the Qt bug contains a possible workaround that does not fix this crash, this may happen because it is not exactly the same problem (even if it is very very similar one) or may be because the workaround just works in some cases, anyway the backtrace is exactly the same in the Qt bug and in this crash

Michał Sawicz (saviq) on 2013-04-19
Changed in touch-preview-images:
assignee: nobody → Albert Astals Cid (aacid)
summary: - Searching for music restarts the shell on manta
+ Searching for music/video restarts the shell on manta
summary: - Searching for music/video restarts the shell on manta
+ Searching for people/music/video restarts the shell on manta
Changed in touch-preview-images:
milestone: none → ubuntu-13.05
Albert Astals Cid (aacid) wrote :

The crash is fixed if you use the new 5.0.2 packages with my ListView crashes, this is Timo's instructions

Timo Jyrinki (timo-jyrinki):
Testable now also for raring (previously saucy) at ppa:canonical-qt5-edgers/qt5-beta-proper
I'd like to have two independent confirmations about the problem being fixed and no regressions (I can combine with bug #1176962 feedback) before doing a PPA copy.
1. apt-add-repository ppa:canonical-qt5-edgers/qt5-beta-proper
2. apt-get update
3. apt-get dist-upgrade
4. poweroff
5. start again, test

kevin gunn (kgunn72) on 2013-05-21
Changed in touch-preview-images:
status: Confirmed → Fix Committed
Albert Astals Cid (aacid) wrote :

qtdeclarative5-qtquick2-plugin is now part of the repositories that feed the image

Changed in touch-preview-images:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers