totem-gstreamer does not support 5.1 surround sound

Bug #40732 reported by Johann Gile on 2006-04-22
58
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Totem
Fix Released
Undecided
Unassigned
Baltix
Undecided
Unassigned
totem (Ubuntu)
Low
Ubuntu Desktop Bugs
Nominated for Intrepid by Jack Senechal
Nominated for Jaunty by Jack Senechal

Bug Description

Steps to reproduce the problem:

Get a file with 5.1 surround sound. I'm using the Dolby City trailer which comes as MPEG 2 with AC-3 audio equivalent to a DVD as well a surround ogg testing file. Both can be downloaded free of charge from http://gstreamer.freedesktop.org/media/large/dolby.vob and http://www-personal.usyd.edu.au/%7Egmonro/download/cid_ind.ogg .

Make sure your 5.1 speaker set is correctly plugged in, a 5.1 switch is active and volume is set to a sane value.
Activate the Gnome Mixer Applet.
Go to Edit->Preferences and make sure Surround, Surround Jack Mode, LFE, and Channel Mode are active.
Go to Playback, set Master, PCM, Surround, Center, and LFE to 100%, then go to Options choose Surround jack mode according to your setup and set Channel Mode to 6ch.
Open a console and execute "speaker-test -c 6 -D plug:surround51", if everything is set up correctly you should be able hear static noise from all 6 speakers.

Use synaptic or apt-get to install these additional packages for the test, make sure universe/multiverse are enabled:
gstreamer0.10-plugins-ugly (for MPEG 2/AC-3 support)
xine-ui
libxine-extracodecs (for MPEG 2/AC-3 support)
mplayer

Start totem, go to Edit->Preferences->Audio, set Audio output type to 5.1-channel.
Open the Ogg test file and observe that you will not get correct surround output.
Open the Dolby test file and observe that you will only get stereo output.

Start xine, right click on th ui and select Settings->Setup->GUI, set Configuration experience level to Master of the known universe, click Apply, select Audio, set Speaker arrangement to Surround 5.1, then click Apply.
Open the Ogg test file and notice you are getting no correct surround sound.
Open the Dolby test file and notice you are getting correct 5.1 surround sound from all 6 speakers.

Start mplayer with "gmplayer -channels 6" from a console.
Open the Ogg test file and notice you are getting correct 5.1 surround sound from all 6 speakers.
Open the Dolby test file and notice you are getting correct 5.1 surround sound from all 6 speakers.

Start vlc.
Open the Ogg test file and observe that you will only get stereo output.
Open the Dolby test file and observe that you will only get stereo output.

Use synaptic or apt-get to install the totem-xine package in order to get the xine backend for totem, totem-gstreamer will be deinstalled automatically.

Start totem, go to Edit->Preferences->Audio, set Audio output type to 5.1-channel.
Open the Ogg test file and observe that you will not get correct surround output.
Open the Dolby file and observe that you will now also get correct 5.1 sorround sound with totem.

Conclusions:

totem-gstreamer does neither play Ogg surround nor AC-3 surround sound correctly.
totem-xine does play AC-3 surround but not Ogg surround sound correctly.
xine plays AC-3 surround but not Ogg surround sound correctly.
mplayer plays AC-3 surround sound as well as Ogg surround sound correctly.
vlc does neither play Ogg surround nor AC-3 surround sound correctly.

totem-gstreamer is the default media player and should support 5.1 surround sound.

Guilty parties involved:

A fresh install of the Ubuntu Dapper Beta from 04/20/2006, no modification except the ones described here.

xine-ui 0.99.4-0ubuntu5
libxine-extracodecs 1.1.1+ubuntu1-2
libxine-main1 1.1.1+ubuntu2-6

mplayer 0.99+1.0pre7try2+cvs20060117-0ubuntu6

vlc 0.8.4.debian-1ubuntu5
vlc-plugin-alsa 0.8.4.debian-1ubuntu5

totem 1.4.0-0ubuntu2
totem-gstreamer 1.4.0-0ubuntu2
totem-xine 1.4.0-0ubuntu2

gstreamer0.10-alsa 0.10.5-0ubuntu3
gstreamer0.10-esd 0.10.2-2ubuntu2
gstreamer0.10-gnomevfs 0.10.5-0ubuntu3
gstreamer0.10-plugins-base 0.10.5-0ubuntu3
gstreamer0.10-plugins-base-apps 0.10.5-0ubuntu3
gstreamer0.10-plugins-good 0.10.2-2ubuntu2
gstreamer0.10-plugins-ugly 0.10.3-0ubuntu1
gstreamer0.10-tools 0.10.4-1ubuntu1
gstreamer0.10-x 0.10.5-0ubuntu3
libgstreamer-plugins-base0.10-0 0.10.5-0ubuntu3
libgstreamer0.10-0 0.10.4-1ubuntu1

Florian Zeitz (florian-zeitz) wrote :

Did you configure VLC to use 5.1 sound (in the audio menu)?
Default is of course stereo...

Johann Gile (jgile-linux) wrote :

I forgot because I'm not familiar with vlc, it gets quite interesting.
If Audio->Audio device is set to 5.1 after opening the file with vlc, both the Dolby and the Ogg test file produce output from all 6 speakers, but the sound is stuttering and vlc spews lots of the following error messages:
alsa error: write failed (Broken pipe)

Sitsofe Wheeler (sitsofe) wrote :

Does totem-gstreamer play the surround wav in ftp://ling.lll.hawaii.edu/pub/greg/Surround-SDL-testfiles.tgz correctly for you?

Changed in totem:
status: Unconfirmed → Needs Info
Changed in totem:
assignee: nobody → desktop-bugs
Johann Gile (jgile-linux) wrote :

No, under my test system described above totem-gstreamer produces just stereo output on Bjorn_Lynne-The_Fairy_Woods(5-1_surround).ogg, dolby-canyon.ogg, and dolby-city.ogg. The files chan-id.wav, dolby-enlighten.wav, and space_battle.wav could not be played as there appears to be no decoder plugin neither in base, bad, or ugly.

Sitsofe Wheeler (sitsofe) wrote :

It is very odd that the .wavs would not play. I'm fairly sure that they are handled by good. Is your system up to date (a fix for multichannel wavs went in a month ago to dapper)? What version(s) of gstreamer are you running now?

Johann Gile (jgile-linux) wrote :

The above results were still from the totem/gstreamer-versions listed in the original bug report.

I just updated to the following versions:

totem 1.4.1-0ubuntu2
totem-gstreamer 1.4.1-0ubuntu2
gstreamer0.10-alsa 0.10.7-0ubuntu3
gstreamer0.10-esd 0.10.3-0ubuntu4
gstreamer0.10-gnomevfs 0.10.7-0ubuntu3
gstreamer0.10-plugins-bad 0.10.3-0ubuntu3
gstreamer0.10-plugins-base 0.10.7-0ubuntu3
gstreamer0.10-plugins-base-apps 0.10.7-0ubuntu3
gstreamer0.10-plugins-good 0.10.3-0ubuntu4
gstreamer0.10-plugins-ugly 0.10.3-0ubuntu3
gstreamer0.10-plugins-ugly-multiverse 0.10.3-2
gstreamer0.10-tools 0.10.6-0ubuntu2
gstreamer0.10-x 0.10.7-0ubuntu3
libgstreamer-plugins-base0.10-0 0.10.7-0ubuntu3
libgstreamer0.10-0 0.10.6-0ubuntu2

totem-gstreamer now also plays the wav, but just as the ogg files only in stereo.

Changed in totem:
status: Needs Info → Unconfirmed
finalbeta (j-greenhouse) wrote :

Perhaps this can help. To get 5.1 playback for everything, I created an .asoundrc in my home dir with:
pcm.!default {
type plug
slave.pcm "surround51"
slave.channels 6
route_policy duplicate
}

After that, everything will be in 5.1 , however GStreamer gave heavy ticking in the sound. Totem-xine, xine play fine now. (ticking sound was reported as a bug http://bugzilla.gnome.org/show_bug.cgi?id=365429 )

Changed in totem:
importance: Medium → Low
Sitsofe Wheeler (sitsofe) wrote :

finalbeta:

Those files already have 5 channels in them - unlike stereo tracks there is already a channel for every speaker so channel duplication isn't really the right thing to do...

Guillaume Desmottes (cassidy) wrote :

I can confirm this bug. Impossible to have 5.1 working with totem-gstreamer with current Feisty.

Sitsofe Wheeler (sitsofe) wrote :

I've finally tested this on my old 4.1 sound card and I've come up against the same problems. First off I can confirm that I never hear anything out of the rear speakers using totem-gstreamer. Secondly I can't get gst-launch-0.10 to do the right thing with a multichannel wav (compared to the output produced by aplay). I shall spin this second issue off into a bug of its own so lets focus on the first issue here.

Description of the problem:
Totem-gstreamer doesn't output sound through the rear speakers despite the audio output being set to 4-channel/4.1-channel/5.0-channel/5.1-channel .

Steps to reproduce:
(assuming you have a working surround soundcard with 4 or more speakers correctly attached)
1. Disconnect your front speakers.
2. Run
speaker-test -Dsurround41 -c 4 -twav
Note that "Rear Right" "Rear Left" are announced through the rear right and rear left speakers respectively.
3. Download and extract
ftp://ling.lll.hawaii.edu/pub/greg/Surround-SDL-testfiles.tgz
4. Run
aplay -Dsurround41 Surround-SDL-testfiles/chan-id.wav
Note how "Rear Left" "Rear Right" are announced through the rear left and rear right speakers respectively.
5. Start totem .
6. Go to Edit -> Preferences. Select the Audio tab and change the Audio output type to 4.1-channel. Click close.
7. Go to Movie -> Open and select Surround-SDL-testfiles/chan-id.wav . Click add.

Expected results:
Audio file to start play. "Rear Left" "Rear Right" are announced through the rear left and rear right speakers respectively.

Actual results.
Audio file to starts playing. No sound is heard at all.

How reproducible is the problem?
The problem is reproducible every time.

Additional information:
Soundcard is a 4.1 Creative Labs SB Live! EMU10k1 (rev 07)
gst-launch-0.10 filesrc location=Surround-SDL-testfiles/chan-id.wav ! wavparse ! audioconvert ! audio/x-raw-int, channels=6 ! alsasink device=surround41
produces sound but not the correct sound compared to aplay. It announces "Centre" from the rear left speaker and "Rear Left/Rear Right" simultaneously from the right hand speaker.

Version information:
Ubuntu Feisty
totem 2.18.1-0ubuntu3
totem-gstreamer 2.18.1-0ubuntu3
gstreamer0.10-plugins-good 0.10.5-1ubuntu2

Sitsofe Wheeler (sitsofe) wrote :

Confirming.

Changed in totem:
status: Unconfirmed → Confirmed
Sitsofe Wheeler (sitsofe) wrote :

Bug #105541 has been filed with regard to multichannel wavs being played out of the wrong speakers. Gstreamer itself seems able to play multichannel AC3 correctly though. Does anyone have a multichannel ogg vorbis file that announces speakers?

Guillaume Desmottes (cassidy) wrote :

There is a upstream bug about 5.1 issues in totem.
http://bugzilla.gnome.org/show_bug.cgi?id=409661

Changed in totem:
status: Unconfirmed → Unknown
Changed in totem:
status: Unknown → Unconfirmed
Changed in totem:
status: New → Incomplete
Sitsofe Wheeler (sitsofe) wrote :

Bug #323298 does not sound like a duplicate of this bug. The description clearly states the problem only occurs when visualisations are enabled...

Id2ndR (id2ndr) wrote :

As noticed by Sitsofe Wheeler, 5.1 surrond sound works great in totem except for audio only file when visualizations is used. Therefore I unmarked bug #323298 as a duplicate of this one (that now could be marked as fixed).

Id2ndR (id2ndr) wrote :

Marking as fixed (see my previous comment for the reason)

Changed in totem (Ubuntu):
status: Confirmed → Fix Released
Jack Senechal (jacksenechal) wrote :

I just tested with visualizations disabled and I'm still seeing this bug. Are you sure it's fixed?

Info:
I'm on Ubuntu 9.04. I get successful surround from the command line with "mplayer -ao alsa -channels 6 testsurround.ogg". VLC can't figure out how to access the device "surround51", so reverts to stereo. And totem only plays stereo.

Id2ndR (id2ndr) wrote :

Yes it works. Try with this file : http://ftp.icm.edu.pl/packages/mplayer/samples/A-codecs/AC3-samples/Canyon-5.1-48khz-448kbit.ac3, play the file, toggle lateral panel on (F9), and look at "Audio" part : you'll get "Surround 5.1" canals.

Jack Senechal (jacksenechal) wrote :

Nope. When I use the VOB file in the bug description above, it says "Surround 5.1" but I can't hear enough to confirm whether it truly is or not. Other than that, all files I've tested, including the one you linked to, show up as "Stereo".

Perhaps you have a more recent version of Totem than I do? Mine says:

Totem Movie Player 2.26.1
... using GStreamer 0.10.22

> Nope. When I use the VOB file in the bug description above, it says
> "Surround 5.1" but I can't hear enough to confirm whether it truly is or
> not. Other than that, all files I've tested, including the one you
> linked to, show up as "Stereo".
>
I think your pulseaudio setup may be wrong. You need to change the
pulseaudio configuration to use more than 2 speakers. You can install
pavucontrol to monitor the output of each channel.

As launchpad is not a forum, you may answer me directly if you want more
precisions.
Others may add more comments later if they got the bug or may write that
it's fixed.
> Perhaps you have a more recent version of Totem than I do? Mine says:
>
> Totem Movie Player 2.26.1
> ... using GStreamer 0.10.22
I've got the same versions as you : the jaunty ones.

Thank you for posting this bug.

As per upstream this issue is Invalid and Launchpad notes Fixed Released.

Unlinking upstream bug, but if this issue resurfaces, please relink with Valid bug.

Marking this bug as Fixed Released.

Changed in totem:
importance: Unknown → Undecided
status: Incomplete → New
Changed in baltix:
status: New → Fix Released
Changed in totem:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.