Support for multiplexed (multi-track) audio

Bug #259044 reported by Kẏra on 2008-08-18
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Amarok
Invalid
Undecided
Unassigned
Banshee
Invalid
Undecided
Unassigned
Exaile
New
Wishlist
Unassigned
GStreamer
Expired
Wishlist
Miro
New
Undecided
Unassigned
Phonon
New
Undecided
Unassigned
Rhythmbox
Expired
Wishlist
Totem
Invalid
Undecided
Unassigned
VLC media player
Won't Fix
Unknown

Bug Description

Free file formats could mimic the functionality of MT9 if the media players handled multiplexed audio. All that would be needed is an advanced audio mixer that can be used to adjust the volume of a particular stream.

About MT9:
http://www.guardian.co.uk/music/2008/may/27/news.seanmichaels

Kẏra (thekyriarchy) wrote :

More specifically, support dynamically mixing several logical tracks from the input stream

Andreas Moog (ampelbein) wrote :

Thanks for reporting. I reported this issue for totem here: http://bugzilla.gnome.org/show_bug.cgi?id=551659

Changed in totem:
importance: Undecided → Unknown
status: New → Unknown
importance: Undecided → Wishlist
status: New → Triaged
assignee: nobody → desktop-bugs
Changed in totem:
status: Unknown → New
Kẏra (thekyriarchy) wrote :

Another problem with this is on the side of the containers. This is all new so no real standard exists for doing this. It can't be addressed form this end though. Just saying, something needs to be done to make this as easy as possible for artists.

Changed in vlc:
importance: Undecided → Unknown
status: New → Unknown
importance: Undecided → Wishlist
status: New → Confirmed
Changed in vlc:
status: Unknown → New
Pedro Villavicencio (pedro) wrote :

gstreamer should support it, rejecting the task of banshee and totme since they use gstreamer as the backend and reassigning the totem one to gstreamer.

Changed in banshee (Ubuntu):
status: New → Invalid
affects: totem (Ubuntu) → gstreamer0.10 (Ubuntu)
Changed in gstreamer:
importance: Undecided → Unknown
status: New → Unknown
Changed in totem:
importance: Unknown → Undecided
status: New → Invalid
Changed in banshee:
status: New → Invalid
Changed in gstreamer:
status: Unknown → New
Changed in gstreamer:
status: New → Incomplete
Kẏra (thekyriarchy) wrote :

For this to happen, music players must be able to play multiple tracks contained in an audiofile simultaneously, and have a separate volume bar for each one. For example, and ogg file could contain a song with a separate track for the audio, guitar, and drums. The media players needs to be able to play all of them at once, and adjust the volume for each track separately.

Changed in gstreamer0.10 (Ubuntu):
status: Triaged → Invalid
Kẏra (thekyriarchy) on 2009-06-14
summary: - Support for multiplexed audio
+ Support for multiplexed audio (MT9 functionality)
Changed in rhythmbox:
importance: Undecided → Unknown
status: New → Unknown

Amarok 2 doesn't handle sound itself, but let's Phonon do it. So this should be assigned to Phonon instead.

Changed in amarok:
status: New → Invalid
Kẏra (thekyriarchy) wrote :

Yes but each individual media player also needs:
- track information exposed through the player interface
- some sort of UI for setting track volumes

Changed in rhythmbox:
status: Unknown → New
reacocard (reacocard) on 2009-06-16
Changed in exaile:
importance: Undecided → Wishlist
Changed in rhythmbox (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Changed in gstreamer0.10 (Ubuntu):
status: Invalid → Triaged
Changed in exaile (Ubuntu):
importance: Undecided → Wishlist
Kẏra (thekyriarchy) wrote :

This is mostly an interface problem--

Example:

A video file might have multiple language tracks. In totem, you can select which track to play.

Just imagine those language tracks, were something else-- instrument tracks, for example (violin, piano)-- and were meant to be played together. An interface would be needed to be able to select which ones to play, and at what volumes.

Changed in gstreamer:
status: Incomplete → Invalid
Changed in vlc:
status: New → Won't Fix
Changed in vlc (Ubuntu):
status: Confirmed → Invalid
Changed in gstreamer:
importance: Unknown → Wishlist
status: Invalid → Expired
Changed in rhythmbox:
importance: Unknown → Wishlist
Kẏra (thekyriarchy) on 2012-01-07
no longer affects: vlc (Ubuntu)
Kẏra (thekyriarchy) on 2012-03-19
summary: - Support for multiplexed audio (MT9 functionality)
+ Support for multiplexed (multi-track) audio
description: updated
Kẏra (thekyriarchy) on 2013-01-27
no longer affects: exaile (Ubuntu)
no longer affects: rhythmbox (Ubuntu)
no longer affects: gstreamer0.10 (Ubuntu)
no longer affects: banshee (Ubuntu)
Changed in rhythmbox:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.