Totem fails to jump to times in video

Bug #200846 reported by Av8or1ab on 2008-03-11
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Totem
Incomplete
High
totem (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: totem

When I watch a movie, doesn't matter what format. If I try to jump to a time with the bar below the video, it will jump to a time past the end of the video and freeze. The program does not crash but it fails to work and has to be closed. Here is some further information:

Dist: Hardy Alpha 6
Package: Totem
Version: 2.21.95
Expectation: Go to the time displayed while dragging
What did happen: It jumps way past, in this case the play time indicates (199:09:34 / 1:58:32)
Other: I am using Compiz on an ATI X1400 card with the 8.3 fglrx driver

Feel free to contact me with any more questions

ProblemType: Bug
Architecture: i386
Date: Mon Mar 10 21:13:12 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/totem-gstreamer
NonfreeKernelModules: fglrx
Package: totem-gstreamer 2.21.95-0ubuntu1
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: totem
Uname: Linux 2.6.24-12-generic i686

Av8or1ab (av8or1ab) wrote :
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in totem:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!.

Changed in totem:
status: Incomplete → Invalid

A video, i.e. mpeg2, is hard to set to a time to continue.

For example: You see a movie for 30 minutes, switch off the computer and want to continue watching the movie later, then it is hard to set the time to continue because mpeg is a compressed format and totem uses bytes to count time in the movie. One byte is not always corresponding to the same time. When totem is started it seeks the movie-file which gives different positions on the slider.

This makes the very hard to set the time.

Changed in totem (Ubuntu):
status: Invalid → New

Too make the description still clearer: A variable bit rate format can't be positioned accurately with a fixed time algorithm.

Dimitrios Symeonidis (azimout) wrote :

Patrik, I cannot find a variable bitrate video on my machine right now, could you attach a small one here as a test case, please?
Thank you

Dimitrios: I have only a big one, which is copyrighted.

Maybe it is possible to find anything free on the Internet? youtube?

I finally found one. Hopefully no one cares about it! It is 46 seconds long.

Dimitrios: Thank you for waiting for the movie...:)
I let you change the status to confirmed!

Benn Snyder (benn.snyder) wrote :

Opened your movie in totem 2.29.91 (in Lucid development). I was unable to jump to different times (the video froze and the indicated time remained the same). When I didn't try to jump to times, the thing indicating the total time of the movie started at 11:58, then started jumping down quickly down to 46 seconds (actual length of the movie). After the video finished playing, I get
"pa_stream_writable_size() failed: Connection terminated"

VLC 1.0.5 plays the file without problems.

Changed in totem (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) wrote :

I have reported this bug for gstreamer-bad since i believe that could be a more related package than totem. https://bugzilla.gnome.org/show_bug.cgi?id=640950

Changed in totem (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Confirmed → Triaged
Changed in totem:
importance: Unknown → High
status: Unknown → New
Changed in totem:
status: New → Confirmed
Changed in totem:
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.