TortoiseBZR 0.5.5 always checks floppy drive

Reported by besy on 2010-07-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
TortoiseBZR
Medium
Unassigned

Bug Description

TortoiseBZR 0.5.5 (included in bzr-2.1.2-1-setup.exe) checks the floppy drive when you start the Windows Explorer, no matter which drive types are enabled in the TortoiseBZR settings. The problem even occurs if there aren't any drive types enabled at all. The noises of the floppy drive get disturbing very quickly.

This problem doesn't exist in the version of TortoiseBZR which is included in bzr-2.0.3-2-setup.exe (I don't remember the version number of TortoiseBZR).

Steps to reproduce:

1. Uninstall TortoiseBZR, TortoiseOverlays, TortoiseSVN etc.

2. Reboot.

3. Install TortoiseBZR using bzr-2.1.2-1-setup.exe. The floppy bug doesn't occur yet! Everything still works fine.

4. Reboot and now notice the floppy bug I described.

I'm using Windows XP SP2 (German).

INADA Naoki (songofacandy) wrote :

What is drive letter of the your floppy drive?
Do you use "whitelist / blacklist" feature?

besy (besy) wrote :

Drive A:

No, I don't use the whitelist or the blacklist feature. Should I?

INADA Naoki (songofacandy) wrote :

Thank you for your report.
I asked about whilte/black list because it is a feature recently added and it may relate to this bug.

Adding "A:\" to black list may help you. But I can't assure because I don't have Floppy drive.

IWATA Hidetaka (hid-iwata) wrote :

I guess, black list setting can't be workaround of this problem.

This patch (marge directive) will fix this problem.

INADA Naoki (songofacandy) wrote :

Thank you, Iwata.

I've merged your patch.

Changed in tortoisebzr:
status: New → Fix Committed
milestone: none → 0.5.6
Changed in tortoisebzr:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers