Accessing Context menu causes Explorer to crash

Bug #422813 reported by plymplan on 2009-09-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
TortoiseBZR
Undecided
Unassigned

Bug Description

When Bazaar Explorer is running, I cannot access Win Explorer context menu. Attempting to access causes Win Explorer to crash.

I used ShellExView to disable TortoiseBazaar ContextMenu Shell Extension which immediately restored context menu function.

I am running WinXP Home SP3

Alexander Belchenko (bialix) wrote :

I don't understand how related Bazaar Explorer (which is simple standalone application) to TortoiseBzr and standard Windows Explorer.

Alexander Belchenko (bialix) wrote :

Do you mean that you don't have context menu in the Bazaar Explorer tree view? This is intended behavior.

Changed in bzr-explorer:
status: New → Incomplete
Ian Clatworthy (ian-clatworthy) wrote :

This sounds like a TortoiseBzr bug? Unlike TortoiseBzr, Bazaar Explorer doesn't hook into Windows internals in any way.

affects: bzr-explorer → tortoisebzr

Please tell me what version of TortoiseBZR and BZR-Explorer you used.
Is this bug reproducable with bzr-1.18.1 and bzr-explorer 0.7?

And please get shell extension's log with tbzrtrace.exe

I am travelling this week; will get back to you later next week when I
return to my office and can review my install.

Chris

> Please tell me what version of TortoiseBZR and BZR-Explorer you used.
> Is this bug reproducable with bzr-1.18.1 and bzr-explorer 0.7?
>
> And please get shell extension's log with tbzrtrace.exe
>
> --
> Accessing Context menu causes Explorer to crash
> https://bugs.launchpad.net/bugs/422813
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in TortoiseBZR: Incomplete
>
> Bug description:
> When Bazaar Explorer is running, I cannot access Win Explorer context
> menu. Attempting to access causes Win Explorer to crash.
>
> I used ShellExView to disable TortoiseBazaar ContextMenu Shell Extension
> which immediately restored context menu function.
>
> I am running WinXP Home SP3
>

Changed in tortoisebzr:
status: Incomplete → Invalid
status: Invalid → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers