One-way sync with Ubuntu One fails if notes were created on U1

Bug #657477 reported by sorodoros on 2010-10-09
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Tomdroid
Fix Released
High
Olivier Bilodeau

Bug Description

No problem getting sync to download notes, but force closes (org.tomdroid) when sync completes. 3rd time was a big crash and shut down my G2.

description: updated
Olivier Bilodeau (plaxx) wrote :

I never used sync aside to test it earlier today with an empty server note list. I'll be away for next few days with no Internet access, hopefully someone else will be able to help you otherwise I advise you to downgrade or start troubleshooting yourself.

sorodoros (elysium-pacbell) wrote :

Thanks for the quick reply. FYI, the same problem when syncing fo SD card. I think I will stay wth .4 becasue the theme is more pleasing. Also note that there is a slight formatiing glitch that was not present in the previous version - text indents are much shorter that they shoud be, and the secondary indent is almost indistinguishable from the primary one (no deeper indent and no change of bullet style.) Enjoy the autumn colors!

Rodja (trappe) wrote :

Hi Sorondors,

could you provide the log output of the force close? Simply run

$ adb logcat

while reproducing the crash should work fine.

Gerhard (gerhard-rauniak-gmail) wrote :
Download full text (8.7 KiB)

Hi Olivier!

First I want to say thanks for your work. Tomdroid is really great.

I think I have the same problem as Sorondors with my HTC Desire and Android 2.2. Below you can find the adb logcat output. I hope it's correct because it was the first time I used adb.

I/ActivityManager( 92): Starting activity: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=org.tomdroid/.ui.Tomdroid }
D/AK8973 ( 72): Compass Start
D/Sensors ( 92): open_akm, fd=149
I/ActivityManager( 92): Displayed activity org.tomdroid/.ui.Tomdroid: 115 ms (total 115 ms)
W/Rosie ( 196): mAddHtcWidgetByOtherActivity = false, mIsOpenSlideWhenLeaveLaunch = true
W/InputManagerService( 92): Ignoring hideSoftInput of: com.android.internal.view.IInputMethodClient$Stub$Proxy@4668a980
V/SyncService(17299): sync progress: 0
V/SnowySyncService(17299): Loading Snowy notes
D/dalvikvm(17299): GC_FOR_MALLOC freed 5169 objects / 303904 bytes in 47ms
I/WebConnection(17299): Response status : HTTP/1.1 200 OK
I/global (17299): Default buffer size used in BufferedReader constructor. It would be better to be explicit if an 8k-char buffer is required.
I/WebConnection(17299): Received : {"user-name": "https://login.launchpad.net/+id/xwLseLR", "last-name": "my account", "notes-ref": {"href": "https://one.ubuntu.com/notes/", "api-ref": "https://one.ubuntu.com/notes/api/1.0/op/"}, "current-sync-guid": "0", "first-name": "my account", "latest-sync-revision": 13}
V/SyncService(17299): sync progress: 30
D/dalvikvm(17299): GC_FOR_MALLOC freed 6123 objects / 377752 bytes in 41ms
D/dalvikvm(17299): GC_FOR_MALLOC freed 1106 objects / 237712 bytes in 38ms
D/NativeCrypto(17299): Freeing OpenSSL session
D/dalvikvm( 7973): GC_EXPLICIT freed 1467 objects / 83352 bytes in 86ms
E/Database( 7973): close() was never explicitly called on database '/data/data/com.handyapps.easymoney/databases/data'
E/Database( 7973): android.database.sqlite.DatabaseObjectNotClosedException: Application did not close the cursor or database object that was opened here
E/Database( 7973): at android.database.sqlite.SQLiteDatabase.<init>(SQLiteDatabase.java:1900)
E/Database( 7973): at android.database.sqlite.SQLiteDatabase.openDatabase(SQLiteDatabase.java:884)
E/Database( 7973): at android.database.sqlite.SQLiteDatabase.openOrCreateDatabase(SQLiteDatabase.java:918)
E/Database( 7973): at android.database.sqlite.SQLiteDatabase.openOrCreateDatabase(SQLiteDatabase.java:911)
E/Database( 7973): at android.app.ContextImpl.openOrCreateDatabase(ContextImpl.java:548)
E/Database( 7973): at android.content.ContextWrapper.openOrCreateDatabase(ContextWrapper.java:203)
E/Database( 7973): at android.database.sqlite.SQLiteOpenHelper.getWritableDatabase(SQLiteOpenHelper.java:98)
E/Database( 7973): at com.handyapps.easymoney.DbAdapter.open(DbAdapter.java:925)
E/Database( 7973): at com.handyapps.easymoney.AlarmService_Service$1.run(AlarmService_Service.java:162)
E/Database( 7973): at java.lang.Thread.run(Thread.java:1102)
I/WebConnection(17299): Response status : HTTP/1.1 200 OK
I/global (17299): Default buffer size used in BufferedReader constructor. It would be better to be explic...

Read more...

Olivier Bilodeau (plaxx) wrote :

Gerhard, your issue has been documented and fixed in a separate branch already (see tomdroid-dev mailing list for details). I'm going to release a 0.4.1 Wednesday evening EDT which fixes this.

Sorodoros, is this your issue? If not, please let us know what it is.

Thanks!

Changed in tomdroid:
assignee: nobody → Olivier Bilodeau (plaxx)
importance: Undecided → High
status: New → Confirmed
sorodoros (elysium-pacbell) wrote :

Not certain, because I have not run the adb logcat (not sure how to do that), but the "org.tomdroid" reference in Gerhard's log seems to suggest at least a similar issue, if not the same issue. Let's see how.4.1 goes and we can have another look if the problem persists. There are also minor formatting issues in .4 as well, and am wondering if they have also been fixed???

Thans for your attention to this!

sorodoros

Gerhard (gerhard-rauniak-gmail) wrote :

Olivier,

Many thanks for the fast reply. Now I will join the mailinglist. :-)

Gerhard

Gerhard (gerhard-rauniak-gmail) wrote :

I just built it from lp:~sil/tomdroid/handle-non-guid-note-ids and it works perfect!

Thanks,

Gerhard

Olivier Bilodeau (plaxx) wrote :

@sorodoros, can you file a separate issue for your formatting issues and upload a picture of your phone. I have a screenshot on my other PC I will upload later there as well for comparison.

Changed in tomdroid:
milestone: none → 0.4.1
summary: - One-way sync works but FC (v.4)
+ One-way sync with Ubuntu One fails if notes were created on U1
Olivier Bilodeau (plaxx) wrote :

Sorry I won't release a 0.4.1 now because I want to confirm/fix another bug before I do so. There's a debug APK available as an attachment in lp:659779 that fixes the issue here try it out if you think you are affected by the bug described here.

Changed in tomdroid:
status: Confirmed → Fix Committed
sorodoros (elysium-pacbell) wrote :

Olivier, no worries. Do you intend to update the indent formatting issues in 0.4.1, too? I posted another reply in that bug too further clarify the indent issue. Thx. sorodoros

No, the 0.4.1 will focus on providing the fix for crasher bugs. I saw your
update regarding the indent formatting. Thank you.

sorodoros (elysium-pacbell) wrote :

0.4.1 = good sync with U1. :)

sorodoros

Olivier Bilodeau (plaxx) wrote :

fix released in 0.4.1

Changed in tomdroid:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers