Sync folder does not remove messages from db

Bug #533933 reported by Bernd Hirschler on 2010-03-07
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Tomdroid
Fix Released
Low
Unassigned

Bug Description

1. If you import messages they are correctly inserted into the internal db.
2. Remove messages from the /tomdroid folder.
3. Re-sync and the messages are still in the internal db.

-> A sync should lead to a re-construction of the internal db and reflect the currently in the tomroid folder available messages.

Additional if there is an error on import it should tell you which file lead to the problem.

Related branches

Olivier Bilodeau (plaxx) wrote :

This is a known issue already tracked in doc/dev/TODO:

"SD card sync:
- Syncing from SD card only adds notes from the SD card and overwrite on identical guid. At some point, we'll have to consider deletions."

> -> A sync should lead to a re-construction of the internal db and reflect the currently in the tomroid folder available messages.

I'm not sure I agree with you here. With editing and online sync, several scenarios are possible and what people expect may differ from user to user (ie should tomdroid/ be the autority, the db, or what's online?)... This will need further discussion and user experience testing. This will probably happen over the mailing list.

If we don't fix this before the next release, I'll rename "Sync" to "Import". That should be clearer about what will happen.

> Additional if there is an error on import it should tell you which file lead to the problem.

Please file another bug to track this issue separately.

Changed in tomdroid:
importance: Undecided → Low
status: New → Confirmed
assignee: nobody → Olivier Bilodeau (plaxx)

Hi,

hopefully in the near future, Dropbox will launch a proper Android client,
then my workflow would be the following.
1st use case:
1. Edit notes on the desktop
2. Dropbox syncs in the background
3. refresh notes from folder, if i delete a message it should also be
removed from the internal db

2nd use case, if a editor is present on the android device:
1. Edit notes on the mobile phone
     2a. Export notes to tomdroid folder, after that it gets synchronized
with Dropbox in the background
or
     2b.If messages are edited, they are automatically updated in the
tomdroid folder

It's clear that the second use case iis muche more complicated and will be a
quest. how to get edits back into the messages...
I see that there are different workflows for each user. Renaming to import
folder would be clearer.

--
MfG Bernd
:x

On Sun, Mar 7, 2010 at 22:34, Olivier Bilodeau <email address hidden>wrote:

> This is a known issue already tracked in doc/dev/TODO:
>
> "SD card sync:
> - Syncing from SD card only adds notes from the SD card and overwrite on
> identical guid. At some point, we'll have to consider deletions."
>
> > -> A sync should lead to a re-construction of the internal db and
> reflect the currently in the tomroid folder available messages.
>
> I'm not sure I agree with you here. With editing and online sync,
> several scenarios are possible and what people expect may differ from
> user to user (ie should tomdroid/ be the autority, the db, or what's
> online?)... This will need further discussion and user experience
> testing. This will probably happen over the mailing list.
>
> If we don't fix this before the next release, I'll rename "Sync" to
> "Import". That should be clearer about what will happen.
>
> > Additional if there is an error on import it should tell you which
> file lead to the problem.
>
> Please file another bug to track this issue separately.
>
> ** Changed in: tomdroid
> Importance: Undecided => Low
>
> ** Changed in: tomdroid
> Status: New => Confirmed
>
> ** Changed in: tomdroid
> Assignee: (unassigned) => Olivier Bilodeau (plaxx)
>
> --
> Sync folder does not remove messages from db
> https://bugs.launchpad.net/bugs/533933
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Benoit Garret (benoit.garret) wrote :

This is something that should be super-easy to implement if you build on top of the web-sync branch. I'm already doing the work for the Tomboy Web synchronization and all you would have to do is build a list of the notes guids present on the sd card.

Olivier Bilodeau (plaxx) on 2011-09-06
Changed in tomdroid:
milestone: none → 0.5.1
Olivier Bilodeau (plaxx) wrote :

Ok, we're decided. Syncing with SD will flush the local database just like the Snowy sync service works now. This will allow for a dropbox-style workflow easiest.

Changed in tomdroid:
assignee: Olivier Bilodeau (plaxx) → Stefan Hammer (j-4)
status: Confirmed → In Progress
Changed in tomdroid:
status: In Progress → Fix Committed
Olivier Bilodeau (plaxx) wrote :

fix available in 0.6.0

Changed in tomdroid:
milestone: 0.6.0 → none
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers