Tomdroid should accept share/send from other apps

Bug #1039104 reported by Frits van Bommel on 2012-08-20
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Tomdroid
Fix Released
Wishlist
Unassigned
Beta
Fix Released
Wishlist
Unassigned

Bug Description

Many Android apps (including Tomdroid 0.7) support a "share" or "send" feature, which can be used to transfer data from one app to another.
Tomdroid should not only be able to "send" but also "receive" such data transfers (creating a new note).
This would make taking notes on content in other apps much more convenient.

(It would also make switching from ColorNotes[1] easier, since for some reason it has no unencrypted export functionality...)

[1]: https://play.google.com/store/apps/details?id=com.socialnmobile.dictapps.notepad.color.note&hl=en

Changed in tomdroid:
importance: Undecided → Wishlist
status: New → Confirmed
status: Confirmed → Triaged

I implemented the feature as suggested here: http://developer.android.com/training/sharing/receive.html
Should be included in rev 412!

Changed in tomdroid:
assignee: nobody → Stefan Hammer (j-4)
milestone: none → 0.7.2
status: Triaged → Fix Committed
NoahY (noahy) wrote :

Nice :) I thought this meant sending and importing .note files, but I see it was just for text. I just added a routine to allow sending and receiving .note files as well, should be in the latest revision.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers