NullPointerException on SD Csrd sync with notes causing parse error

Bug #1038968 reported by Piotr Adamski on 2012-08-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Tomdroid
Fix Released
High
Piotr Adamski
Beta
Fix Released
High
Piotr Adamski

Bug Description

Tested on 4.0 emulator.

Steps to reproduce:
1. Sync notes from sdcard.img that can be found in repository.

After displaying progress dialog tomdroid crashes with NullPointerException

Application crashes because of NullPointerException
08-20 13:04:30.637: ERROR/SyncService(551): Problem syncing in thread
        java.lang.NullPointerException
        at org.tomdroid.sync.SyncService.sendMessage(SyncService.java:519)
        at org.tomdroid.sync.sd.SdCardSyncService.access$300(SdCardSyncService.java:47)
        at org.tomdroid.sync.sd.SdCardSyncService$Worker.run(SdCardSyncService.java:220)
        at org.tomdroid.sync.SyncService$1.run(SyncService.java:156)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1076)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:569)
        at java.lang.Thread.run(Thread.java:856)

Piotr Adamski (mcveat) on 2012-08-20
Changed in tomdroid:
assignee: nobody → Piotr Adamski (mcveat)
status: New → In Progress
Changed in tomdroid:
milestone: none → 0.7.1

In which series is this bug present? stable or beta? I think, i mixed things up before.

Changed in tomdroid:
milestone: 0.7.1 → none
Piotr Adamski (mcveat) wrote :

I found it in beta branch code.

Changed in tomdroid:
milestone: none → 0.7.1
NoahY (noahy) wrote :

This should be fixed in revision 393.

I'm rejecting the merge request, because I think it doesn't solve the problem. If there is a payload, we need to create the syncErrors and add the payload to the empty error list before sending the message.

Let me know if the bug still persists.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers