Todayscope from store is missing child scopes

Bug #1547007 reported by Marius Quabeck on 2016-02-18
46
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Today Scope
High
Kyle Nitzsche

Bug Description

The Todayscope in the store only displays weather.
Its missing the dayscope which is not in the store to display the date/moonphase etc informations and some other scopes.

Nexus 4 rc-proposed r370

Marius Quabeck (marius.quabeck) wrote :
description: updated
Kyle Nitzsche (knitzsche) wrote :

Day scope has not been in the store because it is not displayed on the "Manage" page and therefore cannot be launched independently. I believe the thinking was: if the user cannot launch it separately it should not be in the store.

I am not sure that is compelling any more. If Today scope is in the store, its directly included child scopes should probably also be in the store.

The question of whether to expose the Day scope on the Manage page is probably separate.

Assigning to YC for consideration.

Changed in today-scope:
assignee: nobody → Yuan-Chen Cheng (ycheng-twn)
status: New → Triaged
Yuan-Chen Cheng (ycheng-twn) wrote :

I think provide some more description on how to use today scope is good enough.

Changed in today-scope:
assignee: Yuan-Chen Cheng (ycheng-twn) → Kyle Nitzsche (knitzsche)
Kyle Nitzsche (knitzsche) wrote :

Hi YC:

I think the resolution is to release the Day scope to the store. (And change its scope.ini file so that the scope is visible in the user's Manage page).

Do you agree?

Changed in today-scope:
assignee: Kyle Nitzsche (knitzsche) → Yuan-Chen Cheng (ycheng-twn)
Penk Chen (penk) wrote :

@Kyle,

I think we can make Day scope visible and published without side effect. Thoughts?

tags: added: ota11
Changed in today-scope:
importance: Undecided → High
assignee: Yuan-Chen Cheng (ycheng-twn) → Penk Chen (penk)
Penk Chen (penk) on 2016-04-29
tags: added: ota12
removed: ota11
Changed in today-scope:
assignee: Penk Chen (penk) → Kyle Nitzsche (knitzsche)
NeoTheThird (neothethird) wrote :

Any news on this? Any chance this could be targeted in OTA-15?
Btw, there's now a Bounty on this, if you're interested in dropping a few bucks to the cause, there you go: https://www.bountysource.com/issues/39806151-todayscope-from-store-is-missing-child-scopes

Changed in today-scope:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers