Tivion starts but does not emit any channel

Bug #499616 reported by Lois on 2009-12-22
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Tivion
High
Angel Guzman Maeso

Bug Description

Third time I install it and not play any channels.
Using Ubuntu 9.10.

By default it uses OpenGL to render the player MPlayer.

Related branches

Lois (loislegido) wrote :

Boa Noite:

Pienso que puede ser algún tema de mi ubuntu 9.10 y codecs de video-audio. No funcionan al 100%.

Grazas,

Luis

Angel Guzman Maeso (shakaran) wrote :

Please report in English for next time. Coud you execute the program with 'tivion -d', and attach the file tivion-out-NUMBER and the terminal output to report? Thanks

description: updated
Changed in tivion:
status: New → Incomplete
importance: Undecided → High
assignee: nobody → Angel Guzman Maeso (shakaran)
milestone: none → tivion-0.0.4
summary: - tivion arranca pero no emite ningún canal
+ Tivion starts but does not emit any channel
tags: added: karmic
Davide Lasagna (lasagnadavide) wrote :

I'm also affected by this bug, but i cannot find a way to reproduce it. It is very annoying because sometimes tivion plays a channel, sometimes it does not.

Davide Lasagna (lasagnadavide) wrote :

I'm looking at the mplayer output log in /tmp and i'm relating this log with the behaviour of tivion. I've found that if mplayer is trying to connect to a stream, you can't always change to a new channel. I don't know how tivion do this but i think that when the user tries to change channel the expected behaviour should be that the previous connection is killed and the new one is started.

Try to reproduce this behavior in this way:

1) open tivion, then start channel (UK) BBC Click. It works.
2) try to open channel (UK) Eurosport 1. Then immediately:
3) go back to BBC Click, which fails to open.

Try to do all of this with a real time view of the mplayer log, with "tail -f /tmp/tivion**********". You'll understand what i mean.

Cheers.

Davide

Angel Guzman Maeso (shakaran) wrote :

Yeap, some problem with BBC Click, maybe it change to a new url:
Playing mms://195.90.118.25/eurosport1_1.
STREAM_ASF, URL: mms://195.90.118.25/eurosport1_1
Connecting to server 195.90.118.25[195.90.118.25]: 1755...
Resolving 195.90.118.25 for AF_INET6...
Connecting to server 195.90.118.25[195.90.118.25]: 80...
Resolving 195.90.118.25 for AF_INET6...
Connecting to server 195.90.118.25[195.90.118.25]: 80...
Resolving 195.90.118.25 for AF_INET6...

Exiting... (Quit)
----
The problem in the lastest bzr is that tivion reads the output of mplayer with a thread each 0.5 sec for don't freeze the GUI. The timeout is produced in ms and change. I need read and detect the output more eficient for detect timeout channels.

Changed in tivion:
status: Incomplete → Confirmed

Hi Folks!

I left this bug in stand-by. Thanks for your help.

Right now my problem got worse. I open Tivion and after clicking on BBC
click, for instance, it gets stuck!

Terminal:
uis@loisvalle:/tmp$ cat tivion-out-1262539375
mplayer: symbol lookup error: mplayer: undefined symbol: codec_wav_tags
luis@loisvalle:/tmp$ cat tivion-fifo-1262539375
play

Regards,

Luis

Angel Guzman Maeso wrote:
> Yeap, some problem with BBC Click, maybe it change to a new url:
> Playing mms://195.90.118.25/eurosport1_1.
> STREAM_ASF, URL: mms://195.90.118.25/eurosport1_1
> Connecting to server 195.90.118.25[195.90.118.25]: 1755...
> Resolving 195.90.118.25 for AF_INET6...
> Connecting to server 195.90.118.25[195.90.118.25]: 80...
> Resolving 195.90.118.25 for AF_INET6...
> Connecting to server 195.90.118.25[195.90.118.25]: 80...
> Resolving 195.90.118.25 for AF_INET6...
>
>
> Exiting... (Quit)
> ----
> The problem in the lastest bzr is that tivion reads the output of mplayer with a thread each 0.5 sec for don't freeze the GUI. The timeout is produced in ms and change. I need read and detect the output more eficient for detect timeout channels.
>
> ** Changed in: tivion
> Status: Incomplete => Confirmed
>
>

--
www.lobbycontrol.de <http://www.lobbycontrol.de>

Angel Guzman Maeso (shakaran) wrote :

@Lois: see the faq for codec_wav_tags https://answers.launchpad.net/tivion/+faq/874

Lois (loislegido) wrote :

Hey,

Here I am again with the same bug in Tivion "Lepiron" 0.0.4

I am not able to see any channel. It starts ok but nothing happens.

Any advice?

Ubuntu 9.10 64bit

Do you need more info?

Thanks,

Luis

oscar (garcia-unbc) wrote :

Ubuntu 10.04, tivion 0.0.4 installed from downloaded *.deb
Selecting any channel gives "Nothing playing!", and nothing else. Mplayer works fine.
Terminal output:
vvvvvvvvvvv
oscar@dell-home:~$ tivion
Tivion 0.0.4
Traceback (most recent call last):
  File "tivion.py", line 1430, in on_destroy_event
    return self.on_destroy()
  File "tivion.py", line 1418, in on_destroy
    u.pterminate(self.proc)
AttributeError: Tivion instance has no attribute 'proc'
Traceback (most recent call last):
  File "tivion.py", line 1427, in on_delete_event
    return self.on_destroy()
  File "tivion.py", line 1418, in on_destroy
    u.pterminate(self.proc)
AttributeError: Tivion instance has no attribute 'proc'
Traceback (most recent call last):
  File "tivion.py", line 1418, in on_destroy
    u.pterminate(self.proc)
AttributeError: Tivion instance has no attribute 'proc'
^CProgram terminated by keyboard.
oscar@dell-home:~$
^^^^^^^^^^^

With debug switch:
vvvvvvvvvv
oscar@dell-home:~$ tivion -d
Tivion 0.0.4
*** DEBUG ***
You can see additional output logs of Mplayer in /tmp/tivion-out-1275454186
Note: the output log is removed when the program is closed.
GTK: 2.20.1
PyGTK: 2.17.0
Username: oscar
User language: en_CA.UTF-8
Current locale: C
Current domain: tivion
Default locale dir: /usr/share/locale
Gettext package: None
[0, 0, 0, 0, 0]
Traceback (most recent call last):
  File "tivion.py", line 1430, in on_destroy_event
    return self.on_destroy()
  File "tivion.py", line 1418, in on_destroy
    u.pterminate(self.proc)
AttributeError: Tivion instance has no attribute 'proc'
Traceback (most recent call last):
  File "tivion.py", line 1427, in on_delete_event
    return self.on_destroy()
  File "tivion.py", line 1418, in on_destroy
    u.pterminate(self.proc)
AttributeError: Tivion instance has no attribute 'proc'
Traceback (most recent call last):
  File "tivion.py", line 1418, in on_destroy
    u.pterminate(self.proc)
AttributeError: Tivion instance has no attribute 'proc'
^CProgram terminated by keyboard.
^^^^^^^^^^^^^^^

/tmp/tivion-out-1275454186 is empty.

Angel Guzman Maeso (shakaran) wrote :

Lois and oscar: Could you please test with the lastest development version on launchpad?

For test, you need bazaar:
sudo apt-get install bazaar

And then copy the lastest development files with:
bzr branch lp:tivion

It creates a folder called tivion with all code.

Then run with:
python src/tivion.py

Lois (loislegido) wrote :

Hi there,

I have to inform that I was able to play different channels on Tivion.
But, unfortunately, it depends on the day. Sometimes it works, sometimes
not :-\
I did not do anything special: I upgraded to Ubuntu 10.04 and latest
Tivion's version

I will follow the recommended steps and I will report.

Regards,

Luis

On 02/06/10 11:42, Angel Guzman Maeso wrote:
> Lois and oscar: Could you please test with the lastest development
> version on launchpad?
>
> For test, you need bazaar:
> sudo apt-get install bazaar
>
> And then copy the lastest development files with:
> bzr branch lp:tivion
>
> It creates a folder called tivion with all code.
>
> Then run with:
> python src/tivion.py
>
>

--
www.lobbycontrol.de <http://www.lobbycontrol.de>

Angel Guzman Maeso (shakaran) wrote :

Defering to 0.0.5

Changed in tivion:
milestone: tivion-0.0.4 → tivion-0.0.5
tags: added: video

I have installed mplayer tivion 0.0.4 and also the manner indicated on all the blogs I've read but I still do tivion operate correctly, sometimes it connects me and I can watch one channel but if I change channels I short and I get the phrase ... "there is nothing playing" I installed bazaar and I made ​​the test that you recommend and send you the result of the terminal screen I get. I have Ubuntu as operating 10.04 and I have it installed on a Dell Inspiron 910.
Anyone can help me to run tivion correctly? Mplayer works fine.

pablo@Mundoeco:~$ python '/usr/share/tivion/tivion.py'
Tivion 0.0.4
Traceback (most recent call last):
  File "/usr/share/tivion/tivion.py", line 1427, in on_delete_event
    return self.on_destroy()
  File "/usr/share/tivion/tivion.py", line 1418, in on_destroy
    u.pterminate(self.proc)
AttributeError: Tivion instance has no attribute 'proc'
Traceback (most recent call last):
  File "/usr/share/tivion/tivion.py", line 1418, in on_destroy
    u.pterminate(self.proc)
AttributeError: Tivion instance has no attribute 'proc'

When I run tivion-d I get the following result:
pablo@Mundoeco:~$ tivion -d
Tivion 0.0.4
*** DEPURACIÓN ***
Puedes ver otros registros de salida de Mplayer en /tmp/tivion-out-1303989824
Nota: el registro de salida se elimina cuando se cierra el programa.
GTK: 2.20.1
PyGTK: 2.17.0
Nombre de Usuario: pablo
Idioma del usuario: es_ES.utf8
Localización actual: C
Dominio actual: tivion
Directorio de localización por defecto: /usr/share/locale
Paquete Gettext: None
[0, 0, 0, 0, 0]
Traceback (most recent call last):
  File "tivion.py", line 1427, in on_delete_event
    return self.on_destroy()
  File "tivion.py", line 1418, in on_destroy
    u.pterminate(self.proc)
AttributeError: Tivion instance has no attribute 'proc'
Traceback (most recent call last):
  File "tivion.py", line 1418, in on_destroy
    u.pterminate(self.proc)
AttributeError: Tivion instance has no attribute 'proc'

Hopefully someone can help me fix it.
Thanks

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers