needs porting to new libpanel-applet interface

Bug #865690 reported by Philipp Kern on 2011-10-03
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Timer Applet
Undecided
Unassigned
timer-applet (Debian)
Fix Released
Unknown
timer-applet (Ubuntu)
Undecided
Unassigned

Bug Description

To remain in Debian this software has to be ported to Gtk3 and GNOME3. Please note that panel applets are still supported in GNOME3's fallback mode, so this is orthogonal to the gnome-shell timer extension at Github.

To quote Josselin Mouette who reported the bug in Debian:

The introduction of gnome-panel 3.0 to unstable is imminent. In this
version, the panel-applet library has undergone large changes, and
timer-applet requires changes to support this version:
 * updating to the D-Bus activation mechanism
 * porting to GTK+ 3
 * porting from PyGTK to the GObject Introspection mechanism

You might want to check if upstream developers provide a new version,
compatible with gnome-panel 3.x. Otherwise, porting is a feasible task
if you have a few hours to spare. If you feel like it, the following
guides should help you:
 * http://live.gnome.org/PyGObject/IntrospectionPorting
 * http://developer.gnome.org/gtk3/stable/gtk-migrating-2-to-3.html
 * http://live.gnome.org/GnomeGoals/AppletsDbusMigration

For packages that provide other functionality than the GNOME applet,
you can simply disable it in the build and remove the dependency if
it hasn’t been ported.

For pure applets packages, you should ask for removal from the
archive if you do not intend to port it to the new interface. Such
packages that have not been ported when gnome-panel is ready to
migrate will be kicked out of testing.

Changed in timer-applet (Debian):
status: Unknown → New
Changed in timer-applet (Debian):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in timer-applet (Ubuntu):
status: New → Confirmed
Changed in timer-applet (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.