When using Ctrl in a keybinding it's inputed as <Primary>

Bug #929366 reported by Doug McMahon
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
tilda
Fix Released
Undecided
Sebastian Geiger
tilda (Ubuntu)
Fix Released
Undecided
Sebastian Geiger

Bug Description

Ex. using Ctrl+F6 for pulldown, it's inputed as <Primary>F6
Consequently Ctrl+F6 has no effect, F6 does

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: tilda 0.09.6-2
ProcVersionSignature: Ubuntu 3.2.0-12.21-generic-pae 3.2.2
Uname: Linux 3.2.0-12-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.91-0ubuntu1
Architecture: i386
Date: Thu Feb 9 02:44:00 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120201.1)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: tilda
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Doug McMahon (mc3man) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in tilda (Ubuntu):
status: New → Confirmed
Revision history for this message
Sebastian Geiger (lanoxx) wrote :

This is already fixed in git master, see commit c1c0714e7a5d87ad7d85c3f812a1d19959713bc9 in https://github.com/lanoxx/tilda
It should be very easy to backport this to the existing version in ubuntu, maybe someone with commit access chould cherrypick that commit and upload it?

Changed in tilda (Ubuntu):
status: Confirmed → In Progress
Changed in tilda:
status: New → In Progress
assignee: nobody → Lanoxx (lanoxx)
Changed in tilda (Ubuntu):
assignee: nobody → Lanoxx (lanoxx)
Revision history for this message
Sebastian Geiger (lanoxx) wrote :

Fixed in tilda 1.0 and later.

Changed in tilda:
status: In Progress → Fix Released
Changed in tilda (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers