Tickr throws error and quits when opening rss feed

Bug #1272129 reported by Adam on 2014-01-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Tickr - Feed Reader
High
Emmanuel Thomas-Maurin

Bug Description

Using the feed picker to enter a new url, clicking "OK" or "Add/Upd" throws:

 f_list_search():Invalid node in list

Used different feeds from different sites and yielded same results.

Hello and thank you for reporting that. Which version are you using ?

Changed in tickr:
assignee: nobody → Emmanuel Thomas-Maurin (manu-tm)
status: New → In Progress
Adam (sputnix) wrote :

Version 0.6.4-1 from ubuntu software center.
Re-installed with 0.6.4-1 deb package from http://www.newsrssticker.com/list_all_downloadables.php
and error persisted.

Thanks. Are you tying to add a new feed to an empty list (ie you haven't imported one, nor have you used the default one) ?

Adam (sputnix) wrote :

Adding new rss feed url to an empty list with the feed picker.

Also, the default BBC feed in the config file works without errors, managed to get a different news feed to run, then attempted to add the feed from the same news service through the feed picker and resulted with the same error.

If you have a list of test cases you'd like me to try, let me know. I won't have time to look at them until Monday though.

Adam (sputnix) wrote :

To clarify, the different news feed that worked was an edit of the config file.

Changed in tickr:
importance: Undecided → High

I think the error is thrown when adding a feed (*any* feed) to an *empty* list. I will check the code ASAP. Meanwhile, a workaround is not to start with an empty list.

Copy and paste this in a text editor:

<?xml version="1.0" encoding="UTF-8"?>
<opml version="1.0">
  <head>
    <title>Tickr Feed List</title>
  </head>
  <body>
    <outline title="BBC News - Home" type="rss" xmlUrl="http://newsrss.bbc.co.uk/rss/newsonline_world_edition/front_page/rss.xml" tickrFeedRank=" "/>
  </body>
</opml>

then save as 'feed_list.opml' (or whatever ending with .opml), then import in Tickr. This should enable you to add any valid feed thereafter.

I'm actually attaching the import file.

Adam (sputnix) wrote :

The workaround is functional.
Cheers

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers