clicking on a link dont open the page

Bug #709216 reported by Mauricio Pretto on 2011-01-28
66
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
New
Undecided
Unassigned
gnome-vfs (Ubuntu)
High
Chris Coulson
Natty
High
Chris Coulson
thunderbird (Ubuntu)
Low
Chris Coulson
Natty
Low
Unassigned

Bug Description

Binary package hint: thunderbird

Binary package hint: thunderbird

When clicking on any link on thunderbird it does not open the link on chromium , it does however open the new window (not a tab) but nothing happens

-
reproduce #1
get a email with a link
click on the link

-
reprodude #2
got to language support
new dictionary
get new dictionary link
---

references
https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/709212
https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/589842

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: thunderbird 3.1.7+build3+nobinonly-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
Uname: Linux 2.6.37-12-generic x86_64
Architecture: amd64
Date: Fri Jan 28 10:46:02 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101206)
ProcEnviron:
 LANGUAGE=en
 LANG=pt_BR.utf8
 LC_MESSAGES=en_AG.utf8
 SHELL=/bin/bash
SourcePackage: thunderbird

Mauricio Pretto (pretto) wrote :
Mauricio Pretto (pretto) wrote :

just updated to last package and the problem still happens .......

ii thunderbird 3.1.8+build1+nobinonly-0ubuntu2

User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 GTB7.1 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101207 Lightning/1.0b2 Thunderbird/3.1.7

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIExternalProtocolService.loadUrl]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://communicator/content/contentAreaClick.js :: openLinkExternally :: line 188" data: no]

Reproducible: Always

Steps to Reproduce:
1.Receive any email with a link such as click here to "unsubscribe".
2.Click on the hot link and nothing happens.
3.Error Console has the error listed as shown in details.
4.Right mouse click on hot link, select copy link and paste into Firefox always works.
Actual Results:
When clicking on the link the URL address is shown in the window at the bottom of Thunderbird but it does not connect and does not bring up Firefox. Does not make any difference having Firefox already open.
Note: using Firefox:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 GTB7.1 ( .NET CLR 3.5.30729)

Expected Results:
In the past clicking on the link took me to the web site. However, the current version of Thunderbird does not.

Do not believe any other changes to my systems have been done between prior and current versions of Thunderbird.

Changed in thunderbird (Ubuntu):
status: New → Confirmed

Have you tried resetting your default browser? I.e. select something like Internet Explorer as default, then re-select Firefox as default browser.

Chris Coulson (chrisccoulson) wrote :

Please paste the output of gconftool-2 -R /desktop/gnome/url-handlers

Thanks

Changed in thunderbird (Ubuntu):
status: Confirmed → Incomplete
Mauricio Pretto (pretto) wrote :
Mauricio Pretto (pretto) wrote :

I'm using chromium
with firefox the window opens with the url http://www.%u.com/
which still seems to be a bug
attached is the output for the command you have asked

Chris Coulson (chrisccoulson) wrote :

Thanks. That doesn't really show what I thought I'd see, but I can recreate the issue you see with opening links in Firefox. I guess they're all related.

affects: thunderbird (Ubuntu) → ubuntu
affects: Ubuntu Natty → thunderbird (Ubuntu Natty)
Changed in thunderbird (Ubuntu Natty):
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Undecided → High
status: Incomplete → Triaged
Daniel Holbach (dholbach) wrote :
Download full text (3.7 KiB)

daniel@miyazaki:~$ gconftool-2 -R /desktop/gnome/url-handlers
 /desktop/gnome/url-handlers/unknown:
  command = firefox %u
  needs_terminal = false
 /desktop/gnome/url-handlers/net:
  command = totem "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/lastfm:
  command = rhythmbox "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/feed:
  command = rhythmbox "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/chrome:
  command = /usr/bin/firefox-4.0 %s
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/itpc:
  command = rhythmbox "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/rtsp:
  command = totem "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/zune:
  command = rhythmbox "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/ftp:
  command = /usr/bin/firefox-4.0 %s
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/cdda:
  command = sound-juicer %s
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/uvox:
  command = totem "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/u1ms:
  command = rhythmbox "%s"
  enabled = true
 /desktop/gnome/url-handlers/h323:
  command = ekiga -c %s
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/about:
  command = firefox %u
  needs_terminal = false
 /desktop/gnome/url-handlers/mailto:
  command = thunderbird %s
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/mumble:
  command = mumble %s
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/http:
  command = firefox %u
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/mmsh:
  command = totem "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/mms:
  command = totem "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/rtp:
  command = totem "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/irc:
  command = xchat-gnome --existing --url=%s
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/pnm:
  command = totem "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/https:
  command = firefox %u
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/trash:
  command = nautilus "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/callto:
  command = gnomemeeting -c %s
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/ghelp:
  command = gnome-help "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/zcast:
  command = rhythmbox "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/icy:
  command = totem "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/magnet:
  command = transmission '%s'
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/note:
  command = tomboy --open-note '%s'
  enabled = true
 /desktop/gnome/url-handlers/itms:
  command = rhythmbox "%s"
  needs_terminal = false
  enab...

Read more...

Changed in thunderbird:
importance: Unknown → Medium
status: Unknown → New

(In reply to comment #2)
> dup of bug 542046 ?

Hubert ?

Mauricio Pretto (pretto) wrote :

this is fixed with last natty updates.

Martin Pitt (pitti) wrote :

Mauricio, thanks for testing!

Changed in thunderbird (Ubuntu Natty):
status: Triaged → Fix Released
Daniel Holbach (dholbach) wrote :

It doesn't work for me.

Mauricio Pretto (pretto) wrote :

After today's update , the bug is back :(

Changed in thunderbird (Ubuntu Natty):
status: Fix Released → Confirmed
Chris Coulson (chrisccoulson) wrote :

Right, I was surprised that it would have been fixed. Nothing has changed in Thunderbird or any other part of the stack which might cause this

Changed in thunderbird (Ubuntu Natty):
status: Confirmed → Triaged
Timo Aaltonen (tjaalton) wrote :

I upgraded from lucid to natty on the 8th, and noticed this behaviour with firefox. Two days ago I switched to chromium, and the links opened there just fine. Then I ran the updates and it stopped working. Just FYI

Timo Aaltonen (tjaalton) wrote :

I see that there were new updates of desktop-file-utils and shared-mime-info that got installed that day..

Chris Coulson (chrisccoulson) wrote :

TBH, it wouldn't surprise me if this is related to https://bugzilla.mozilla.org/show_bug.cgi?id=611953, but I need to investigate it further this week

Mauricio Pretto (pretto) wrote :

I just noticed that the new windows which opens when you click on a link with thunderbird isn't a blank is your default home page
I used to have my home set to blank now is opening my home page .

James Troup (elmo) on 2011-02-21
tags: added: regression-proposed
Mauricio Pretto (pretto) wrote :

after todays updates , I have installed the following packages
ii thunderbird 3.1.8+build3+nobinonly-0ubuntu1 mail/news client with RSS and integrated spam filter support
ii thunderbird-globalmenu 3.1.8+build3+nobinonly-0ubuntu1 Unity appmenu integration for Thunderbird
ii thunderbird-gnome-support 3.1.8+build3+nobinonly-0ubuntu1 Support for Gnome in Mozilla Thunderbird

the problem persists

Changed in thunderbird (Ubuntu Natty):
milestone: none → ubuntu-11.04-beta-1
Chris Coulson (chrisccoulson) wrote :

Removing the upstream link, as it's a different problem. This is because thunderbird is still using gnomevfs for launching external URI's, and the changes to protocol handler registration in natty has broken gnomevfs to the point of being pretty much useless now

Changed in thunderbird:
importance: Medium → Undecided
Dimitrios Symeonidis (azimout) wrote :

Open gconf-editor and change the following two settings from "firefox %u" to "firefox %s":

/desktop/gnome/url-handlers/http/command
/desktop/gnome/url-handlers/https/command

Timo Aaltonen (tjaalton) wrote :

thanks Dimitrios, that works!

Chris Coulson (chrisccoulson) wrote :

Note, that isn't a fix because those gconf values are all stale entries that won't match your preferred applications, and won't work on a new install (those gconf entries are all obsolete and are not the way to register URI handlers anymore)

Chris Coulson (chrisccoulson) wrote :

I didn't realise that gnome-default-application-properties was still setting the gconf entries in /desktop/gnome/url-handlers. gnome-default-application-properties is actually setting broken values now, as it uses the Exec line from applications desktop files, and these use "%u" as the URI placeholder (which gnome-vfs doesn't understand). We'll work around this in gnome-vfs for now (see bug 739416), although I'll still track this in tbird.

Changed in gnome-vfs (Ubuntu Natty):
importance: Undecided → High
status: New → Triaged
Changed in thunderbird (Ubuntu Natty):
importance: High → Low
Changed in gnome-vfs (Ubuntu Natty):
assignee: nobody → Chris Coulson (chrisccoulson)
milestone: none → ubuntu-11.04-beta-1
Changed in thunderbird (Ubuntu Natty):
milestone: ubuntu-11.04-beta-1 → ubuntu-11.04
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-vfs - 1:2.24.4-0ubuntu3

---------------
gnome-vfs (1:2.24.4-0ubuntu3) natty; urgency=low

  * Fix LP: #739416 - Preferred Applications uses %u instead of %s when
    setting browser. Our new gnome-default-application-properties sets
    the URI handlers in gconf using the Exec line from the applications
    desktop file rather than the old xml files that used to ship with
    gnome-control-center. The Exec info from the desktop file uses "%u"
    as a URI placeholder, rather than "%s" which is what gnomevfs understands.
    Make gnomevfs understand "%u" too so we don't break applications that still
    rely on it.
    - add debian/patches/31_gio_uri_placeholder.patch
    - update debian/patches/series
    - This also works around LP: #709216 for now
 -- Chris Coulson <email address hidden> Tue, 22 Mar 2011 17:38:37 +0000

Changed in gnome-vfs (Ubuntu Natty):
status: Triaged → Fix Released
Martin Pitt (pitti) wrote :

Thanks Chris! Removing the natty task then.

Changed in thunderbird (Ubuntu Natty):
milestone: ubuntu-11.04 → none
status: Triaged → Won't Fix
assignee: Chris Coulson (chrisccoulson) → nobody
Mauricio Pretto (pretto) wrote :

this is yet not fixed for me.

Mauricio Pretto (pretto) wrote :

YESSSSSSSS
finally working !!!!
thank you!!!

Launchpad Janitor (janitor) wrote :
Download full text (7.5 KiB)

This bug was fixed in the package thunderbird - 5.0~b1+build2+nobinonly-0ubuntu1

---------------
thunderbird (5.0~b1+build2+nobinonly-0ubuntu1) oneiric; urgency=low

  * New upstream release from the miramar channel (THUNDERBIRD_5_0b1_BUILD2)
    - Fixes LP: #766022

  * Switch to comm-miramar
    - update debain/mozclient/thunderbird.conf
  * Update globalmenu-extension to 1.6
  * Align packaging with firefox:
    - rename debian/apport/blacklist => debian/apport/thunderbird.in
    - rename debian/control => debian/control.in
    - rename debian/thunderbird-dev.install =>
       debian/thunderbird-dev.install.in
    - rename debian/thunderbird-gnome-support.install =>
       debian/thunderbird-gnome-support.install.in
    - rename debian/thunderbird.desktop => debian/thunderbird.desktop.in
    - rename debian/thunderbird.install => debian/thunderbird.install.in
    - rename debian/thunderbird.manpages => debian/thunderbird.manpages.in
    - update debian/apport/thunderbird.in
    - update debian/control.in
    - update debian/rules
    - update debian/thunderbird.sh.in
    - update debian/thunderbird.xml.in
    - update debian/thunderbird-dev.install.in
    - update debian/thunderbird-gnome-support.install
    - update debian/thunderbird.desktop.in
    - update debian/thunderbird.install.in
    - update debian/thunderbird.manpages
    - added debian/thunderbird-dev.links.in
    - added debian/thunderbird-globalmenu.dirs.in
    - added debian/thunderbird-mozsymbols.install.in
    - added debian/thunderbird.dirs.in
    - added debian/thunderbird.links.in
    - added debian/thunderbird.lintian-overrides.in
  * Build language packs directly from the thunderbird source
    + Include compare-locales FIREFOX_5_0b1_BUILD1 from
      http://hg.mozilla.org/build/compare-locales. It's needed for merging
      en-US strings with incomplete locales
    + Pull l10n data in to tarball from bzr
      - update debian/mozclient/thunderbird.conf
    + Configure build for creating language packs by configuring with
      "--with-l10n-base="
      - update debian/mozconfig.in
    + Store the list of locales to ship, and provide a way of automatically
      generating that list and the control file entries from the upstream
      source. Also provide a way to blacklist languages. We map languages
      to package names using langpack-o-matic (and also get descriptions
      from there too)
      - update debian/rules
      - add debian/locales.shipped
      - add debian/control.langpacks
      - add debian/control.langpacks.unavail
      - update debian/control
      - add debian/locales.unavailable
      - add debian/refresh-supported-locales.pl
    + Add common-build-indep hook to build the translation xpi's
      - update debian/rules
    + Add common-binary-post-install-indep to install the xpi's in to the correct
        debian packages
      - update debian/rules
      - add debian/get-xpi-id.py
    + When rebuilding debian/control in the clean target, fail the build
      if the control file was out-of-date. This ensures that we don't
      accidentally drop language packs, and forces me to maintain an
      up-to-date control file in bzr
      - update d...

Read more...

Changed in thunderbird (Ubuntu):
status: Triaged → Fix Released
Amir Marandi (marandi) wrote :

I am still struggling with Thunderbird not opening link in a web browser. I have FireFox and Epiphany installed (Ubuntu 11.04) and links from Thunderbird does not open in either browser. If I install Chrome, it immediately opens the link in Chrome. How do I fix this so I can use FireFox?

Bem Jones-Bey (ajani) wrote :

I had this problem with Firefox in Natty as well (after upgrading from 10.10). After reading this bug and looking at what gets set in gconf when I change the browser to Chrome, I noticed that the setting for Chrome had %U (note the capital U) after the command in gconf. And when I looked at the Properties for Chrome in the Menu editor, I noticed that the Command also has the %U at the end of it. Looking at Firefox in the menu editor showed that the Command didn't have the %U. So I added the %U to the end of the Command line for Firefox in my menu and then changed my default browser to Chrome and then back to Firefox, and now links launch in Firefox like expected.

(Attempting to manually edit the gconf lines like suggested earlier in this bug didn't work, it looks like neither %u or %s work if changed directly in gconf, I didn't check anything else. But with previous posts mentioning that things aren't reading from gconf anymore, maybe it's just that Pidgin doesn't read gconf, and it's getting it's setting from somewhere else that was also incorrect.)

Bem Jones-Bey (ajani) wrote :

I forgot to mention that when testing it, I was clicking on the link in Pidgin, not Thunderbird, but I did have this problem in Thunderbird as well.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.