broken charset/encoding autodetection for encrypted messages

Bug #1357227 reported by Thorsten Glaser on 2014-08-15
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
New
Medium
kdepim (Debian)
Fix Released
Unknown
thunderbird (Ubuntu)
Undecided
Unassigned

Bug Description

Version: 1:31.0+build1-0ubuntu0.12.04.1

Hi,

this is a bug Mozilla™ Thunderbird and KDEPIM share:

When I send an Inline PGP encrypted message, whose body is using UTF-8, to another user, the message is ASCII armoured (and thus 7bit). The other user, running Thunderbird or Kontact, (or my own Kontact instance in the “sent-mail” folder), gets the message and interprets the post-decryption body as ISO-8859-1 (or Windows-1252, probably) instead of UTF-8.

Manually switching the encoding to Unicode in the menu corrects this… for this one message. (See https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/1108980 as well.)

The problem here is that the human message encoding (everything within the PGP armour) must be separated from the transport message encoding (the RFC822 message in which the “-----BEGIN PGP MESSAGE”…“END PGP MESSAGE-----” is transmitted) must be separated from each other, which they aren’t.

Please fix this, it harms using those MUAs in an enterprise environment.

User Agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140717132905

Steps to reproduce:

The Thunderbird user received an Inline PGP encrypted eMail from me. The content of that was UTF-8 encoded; the transport message body contained an ASCII-armoured PGP message.

Actual results:

The Thunderbird user got the message interpreted as ISO-8859-1 or Windows-1252, instead of UTF-8. This was also reported as: https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/1357227

This means the automatic detection of UTF-8 is broken, and/or the encoding of the RFC822 transport container is mixed up with the encoding of the message.

Manually selecting Unicode from the message encoding menu, the message is displayed correctly. Switching away from the message and back to it causes the setting to reset; this was also reported as: https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/1108980

Expected results:

The user should have seen the Unicode characters in the message correctly, instead of mojibake.

Changed in kdepim (Debian):
status: Unknown → New
Changed in thunderbird:
importance: Unknown → Medium
status: Unknown → New

Please attach a sample mail (save as .eml)

Changed in kdepim (Debian):
status: New → Confirmed

Created attachment 8474434
public part of test GPG key

Created attachment 8474435
secret part of test GPG key

Created attachment 8474439
eMail exhibiting the bug

OK. This eMail contains a PGP message encrypted to 0xD1D8EFD2 whose public and secret (passphrase is 123123) key I also attached. I just confirmed with a coworker that this does exhibit the bug.

Changed in kdepim (Debian):
status: Confirmed → Fix Released
gf (gf-interlinks) wrote :

Hello Thorsten,
Thank you for submitting this bug and reporting a problem with Thunderbird. You made this bug report in 2014 and there have been several versions of Ubuntu and Thunderbird since then.

Could you confirm that this is no longer a problem and that we can close the ticket?
If it is still a problem, are you still interested in finding a solution to this bug?
If you are, could you run the following (only once):
apport-collect 1357227
and upload the updated logs and and any other logs that are relevant for this particular issue.

Thank you again for helping make Ubuntu and Thunderbird better.
G

Changed in thunderbird (Ubuntu):
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.