Thunar crashed with signal 7 in jpeg_fill_bit_buffer()

Bug #377847 reported by Michael Moroni on 2009-05-18
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
thunar
Confirmed
Unknown
thunar (Ubuntu)
Medium
Unassigned
tumbler (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: thunar

I was rotating an image and saving it. After ding so I was moving the file into OpenOffice Draw, by taking pressed the leftclick button. Suddenly Thunar closed.

OS: Xubuntu 9.04

thunar:
  Installed: 1.0.0-1ubuntu3
  Candidate: 1.0.0-1ubuntu3
  Version table:
 *** 1.0.0-1ubuntu3 0
        500 http://archive.ubuntu.com jaunty/universe Packages
        100 /var/lib/dpkg/status

gpicview:
  Installed: 0.1.11-1
  Candidate: 0.1.11-1
  Version table:
 *** 0.1.11-1 0
        500 http://archive.ubuntu.com jaunty/universe Packages
        100 /var/lib/dpkg/status

ProblemType: Crash
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/Thunar
Package: thunar 1.0.0-1ubuntu3
ProcCmdline: Thunar --sm-client-id 29b7487fb-68b9-422a-bb08-fcc653f96c17 --daemon
ProcEnviron:
 LANG=eo.UTF-8
 SHELL=/bin/bash
Signal: 7
SourcePackage: thunar
StacktraceTop:
 jpeg_fill_bit_buffer () from /usr/lib/libjpeg.so.62
 ?? () from /usr/lib/libjpeg.so.62
 ?? () from /usr/lib/libjpeg.so.62
 ?? () from /usr/lib/libjpeg.so.62
 jpeg_read_scanlines () from /usr/lib/libjpeg.so.62
Title: Thunar crashed with signal 7 in jpeg_fill_bit_buffer()
Uname: Linux 2.6.28-12-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Michael Moroni (airon90) wrote :
visibility: private → public

StacktraceTop:jpeg_fill_bit_buffer (state=0xb45aacc8, get_buffer=-1353537573,
decode_mcu (cinfo=0xb45aae68, MCU_data=0x9790be4)
decompress_onepass (cinfo=0xb45aae68, output_buf=0x9790c44)
process_data_simple_main (cinfo=0xb45aae68,
jpeg_read_scanlines (cinfo=0xb45aae68,

Changed in thunar (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Charlie Kravetz (charlie-tca) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at: http://bugzilla.xfce.org/show_bug.cgi?id=5375

Changed in thunar (Ubuntu):
status: New → Triaged
Changed in thunar:
status: Unknown → Confirmed
Lionel Le Folgoc (mrpouit) wrote :

Not sure thunar 1.2.x is still affected. But its thumbnailing code has been moved to tumbler, so it's likely tumbler is affected.

Lionel Le Folgoc (mrpouit) wrote :

The code isn't in Thunar 1.2.x, and there have been many changes in tumbler, so I can't reproduce (also, if someone is able to reproduce, a fresh strack trace is needed). Closing.

Changed in tumbler (Ubuntu):
status: New → Invalid
Changed in thunar (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.