Opening multiple instances of thunar causes system freeze

Bug #317920 reported by greenstuff on 2009-01-16
116
Affects Status Importance Assigned to Milestone
Thunar File Manager
Confirmed
Unknown
thunar (Ubuntu)
Undecided
Unassigned

Bug Description

Problem:
========

Opening multiple instances of thunar causes system freeze.

I've tested this on two different systems and two distribution versions:
1) a one year old intel dualcore HP laptop (mythbuntu 8.04)
2) a 7 year old desktop (mythBuntu 8.04 and Ubuntu 8.10).

How to reproduce
==============

Open thunar and set in preferences (edit/preferences) the following:
[tab display]
- view new folders using: detailed list view
- sort folders before files: checked
- show thumbnails : checked
- date format: yyyy-mm-dd hh:mm:ss

close thunar to make sure settings are used for all new thunar instances.

- Open three thunar instances and click through some folders with all three
- close two instances
- open two instance and click through some folders.
- close one instance
- etc.

within 1 minute al thunar instances get freezed. The rest of the system is still responding almost as quick as before.

Feel free to contact me for any question you have about this report.

Cheers,

John

Related branches

Vincent (vinnl) wrote :

I reported it upstream, please follow it there: http://bugzilla.xfce.org/show_bug.cgi?id=4820

Thanks, I see I forgot about xfce ;)

Cheers,

John

2009/1/17 Vincent <email address hidden>:
> I reported it upstream, please follow it there:
> http://bugzilla.xfce.org/show_bug.cgi?id=4820
>
> ** Bug watch added: Xfce Bugzilla #4820
> http://bugzilla.xfce.org/show_bug.cgi?id=4820
>
> ** Also affects: thunar via
> http://bugzilla.xfce.org/show_bug.cgi?id=4820
> Importance: Unknown
> Status: Unknown
>
> --
> Opening multiple instances of thunar causes system freeze
> https://bugs.launchpad.net/bugs/317920
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Thunar file manager: Unknown
> Status in "thunar" source package in Ubuntu: New
>
> Bug description:
> Problem:
> ========
>
> Opening multiple instances of thunar causes system freeze.
>
> I've tested this on two different systems and two distribution versions:
> 1) a one year old intel dualcore HP laptop (mythbuntu 8.04)
> 2) a 7 year old desktop (mythBuntu 8.04 and Ubuntu 8.10).
>
>
> How to reproduce
> ==============
>
> Open thunar and set in preferences (edit/preferences) the following:
> [tab display]
> - view new folders using: detailed list view
> - sort folders before files: checked
> - show thumbnails : checked
> - date format: yyyy-mm-dd hh:mm:ss
>
> close thunar to make sure settings are used for all new thunar instances.
>
>
> - Open three thunar instances and click through some folders with all three
> - close two instances
> - open two instance and click through some folders.
> - close one instance
> - etc.
>
> within 1 minute al thunar instances get freezed. The rest of the system is still responding almost as quick as before.
>
> Feel free to contact me for any question you have about this report.
>
> Cheers,
>
> John
>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunar - 0.9.99.1-0ubuntu1

---------------
thunar (0.9.99.1-0ubuntu1) jaunty; urgency=low

  * Merge from Debian pkg-xfce UNRELEASED (r2643), remaining Ubuntu changes:
    - debian/control:
      + use our Vcs-* fields.
      + build depends on gtk-doc-tools.
      + thunar-data: conflicts/replaces thunar-doc, libthunar-vfs-1-dev
        (<= 0.9.0-3ubuntu1).
    - debian/patches:
      + 06_fix-menu-icons.patch: correctly displays themed icons even if there's
        a dot in the middle of the filename (see Xfce #3614).
      + xubuntu-fix-desktop-files.patch: various fixes to desktop files:
        . make thunar and thunar-bulk-rename appear under Accessories not System
        . make destop-file-validate happy (remove 'Encoding' and 'Application;')
        . add 'OnlyShowIn="XFCE;"' to Thunar-folder-handler.desktop so that
          GNOME defaults to Nautilus and not Thunar.
  * Bugs fixed by this new release:
    - "Querying Thunar /proc directory causes hang" (LP: #162448)
    - "Thunar does not respond after second window is opened" (LP: #163587)
    - "Thunar does not show if drive is mounted" (LP: #181117)
    - "xfce desktop does not respect freedesktop desktop settings" (LP: #220318)
    - "thunar swaps behavior of forward / back (next / previous) buttons"
      (LP: #234217)
    - "Xubuntu 8.04 X64 Thunar randomly freezes - hidden files/tree view"
      (LP: #293839)
    - "Opening multiple instances of thunar causes system freeze" (LP: #317920)
  * debian/patches/02_fix-font-thumbnailer-desktop-file.patch: add missing keys
    in the font thumbnailer's desktop file (LP: #318290).

 -- Lionel Le Folgoc <email address hidden> Fri, 30 Jan 2009 14:47:35 +0100

Changed in thunar:
status: New → Fix Released
Changed in thunar:
status: Unknown → Confirmed
greenstuff (dutchtest) on 2010-05-13
visibility: public → private
Charlie Kravetz (charlie-tca) wrote :

There is no information in this report that requires it to be private. Marking it private does make it harder for anyone else that experiences this issue to add to this report.

visibility: private → public
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.