"Request cancelled" error messages using ListView

Bug #1501349 reported by Arthur Mello on 2015-09-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Alejandro J. Cura
Thumbnailer
Fix Released
High
Michi Henning

Bug Description

While running the attached qml app to test the fixes for bug #1484914 in krillin with --channel=ubuntu-touch/rc-proposed/bq-aquaris.en (r136) we can see a lot of error logs like on stdout like these:

ThumbnailerImageResponse::dbusCallFinished(): D-Bus error: "Request cancelled"
"Request cancelled"

To run it make sure you have at least 100 photos in /home/phablet/Pictures/com.ubuntu.camera and exec:

$ phablet-shell
$ qmlscene --desktop_file_hint=/usr/share/applications/address-book-app.desktop leako.qml

Related branches

Arthur Mello (artmello) wrote :
Bill Filler (bfiller) on 2015-09-30
Changed in canonical-devices-system-image:
milestone: none → ww46-2015
assignee: nobody → Alejandro J. Cura (alecu)
importance: Undecided → High
Michi Henning (michihenning) wrote :

This could be related to the request limiter inside the thumbnailer. (I'm guessing here only, I haven't tried this yet.)

One of the first things to try would be with this branch: lp:~michihenning/thumbnailer/qt-rate-limiterlp:thumbnailer/devel

That will at least narrow the problem down. If bug persists with this, I have no idea where the problem might be right now. But I'd love to know how we can provoke the QML side to call cancel() on a request. (Right now, this is essentially untested because we simply don't know how to make that happen.) Albert, could you help out with that?

Changed in thumbnailer:
assignee: nobody → James Henstridge (jamesh)
Albert Astals Cid (aacid) wrote :

To make a cancel() request happen just make the item that requested the image be deleted (you can try either Loader or a Listview i guess) before the image has been returned.

Michi Henning (michihenning) wrote :

Thanks for that, will try!

Michi Henning (michihenning) wrote :

I can reproduce this.

Changed in thumbnailer:
assignee: James Henstridge (jamesh) → Michi Henning (michihenning)
Changed in thumbnailer:
status: New → In Progress
importance: Undecided → High
Changed in canonical-devices-system-image:
status: New → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:thumbnailer/devel at revision 292, scheduled for release in thumbnailer, milestone Unknown

Changed in thumbnailer:
status: In Progress → Fix Committed
Changed in thumbnailer:
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments