[6.1] required binary fields are not enforced on web interface

Bug #1053367 reported by Carlos Sierra Andrés on 2012-09-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Odoo Web (MOVED TO GITHUB)
Status tracked in Trunk
6.1
Confirmed
Low
OpenERP Publisher's Warranty Team
Trunk
Invalid
Low
Unassigned
Therp Backports (Deprecated)
Undecided
Unassigned
Web-6.1
Undecided
Stefan Rijnhart (Opener)

Bug Description

OpenERP web interface is not enforcing required binary fields.
Same view using GTK interface works as expected.

To reprodyce simply create a required binary field in a view and save the form leaving the binary field empty. The web interface will save without complaining.

When there are other required fields on the form view you can see all of them getting red, except binary fields.

Related branches

patch -p1 < binary_field_validation.patch

This patch seems to work for me.

Changed in openerp-web:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → OpenERP Publisher's Warranty Team (openerp-opw)
summary: - required binary fields are not enforced on web interface
+ [6.1] required binary fields are not enforced on web interface

Hello Carlos,

In trunk, It's working fine. This Issue is affected only 6.1. and this patch are working well at my end.
So I am assign this Issue to OPW team.

Thanks for the reporting!

patch -p1 < binary_field.patch

I removed the former patch because it prevented reports to be used in the presence of these fields. This patch should work better.

Changed in therp-backports:
status: New → Fix Committed
Changed in therp-backports:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers