"Socket is not connected" error shown on console when running locally

Reported by Emily Bache on 2013-04-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
TextTest
Undecided
Unassigned

Bug Description

I'm running without a queueing system, using the console. TextTest appears to work correctly, but I get this error message on the console:

Q: Submitting APPLY test-case GuidingTest to default local queue
----------------------------------------
Exception happened during processing of request from ('192.168.1.92', 60702)
Traceback (most recent call last):
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py", line 582, in process_request_thread
    self.finish_request(request, client_address)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py", line 323, in finish_request
    self.RequestHandlerClass(request, client_address, self)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py", line 639, in __init__
    self.handle()
  File "/Users/emily/devtools/texttest-3.25/source/lib/queuesystem/masterprocess.py", line 804, in handle
    self.handleRequestFromHost(self.getHostName(clientHost), identifier)
  File "/Users/emily/devtools/texttest-3.25/source/lib/queuesystem/masterprocess.py", line 844, in handleRequestFromHost
    self.connection.shutdown(socket.SHUT_RD)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/socket.py", line 224, in meth
    return getattr(self._sock,name)(*args)
error: [Errno 57] Socket is not connected
----------------------------------------
----------------------------------------
Exception happened during processing of request from ('192.168.1.92', 60703)
Traceback (most recent call last):
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py", line 582, in process_request_thread
    self.finish_request(request, client_address)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py", line 323, in finish_request
    self.RequestHandlerClass(request, client_address, self)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py", line 639, in __init__
    self.handle()
  File "/Users/emily/devtools/texttest-3.25/source/lib/queuesystem/masterprocess.py", line 804, in handle
    self.handleRequestFromHost(self.getHostName(clientHost), identifier)
  File "/Users/emily/devtools/texttest-3.25/source/lib/queuesystem/masterprocess.py", line 844, in handleRequestFromHost
    self.connection.shutdown(socket.SHUT_RD)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/socket.py", line 224, in meth
    return getattr(self._sock,name)(*args)
error: [Errno 57] Socket is not connected
----------------------------------------
----------------------------------------
Exception happened during processing of request from ('192.168.1.92', 60704)
Traceback (most recent call last):
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py", line 582, in process_request_thread
    self.finish_request(request, client_address)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py", line 323, in finish_request
    self.RequestHandlerClass(request, client_address, self)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py", line 639, in __init__
    self.handle()
  File "/Users/emily/devtools/texttest-3.25/source/lib/queuesystem/masterprocess.py", line 804, in handle
    self.handleRequestFromHost(self.getHostName(clientHost), identifier)
  File "/Users/emily/devtools/texttest-3.25/source/lib/queuesystem/masterprocess.py", line 844, in handleRequestFromHost
    self.connection.shutdown(socket.SHUT_RD)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/socket.py", line 224, in meth
    return getattr(self._sock,name)(*args)
error: [Errno 57] Socket is not connected
----------------------------------------
S: APPLY test-case GuidingTest FAILED on Emily-Baches-MacBook-Pro-2.local : new results in errors,output
View details(v), Save(s) or continue(any other key)?
v¨^H
---------- New result in errors ----------
---------- New result in output ----------
hello world
<See also mate window for details of output>
Save(s) or continue(any other key)?

Terminating graphical viewer...
----------------------------------------
Exception happened during processing of request from ('192.168.1.92', 60705)
Traceback (most recent call last):
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py", line 582, in process_request_thread
    self.finish_request(request, client_address)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py", line 323, in finish_request
    self.RequestHandlerClass(request, client_address, self)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py", line 639, in __init__
    self.handle()
  File "/Users/emily/devtools/texttest-3.25/source/lib/queuesystem/masterprocess.py", line 804, in handle
    self.handleRequestFromHost(self.getHostName(clientHost), identifier)
  File "/Users/emily/devtools/texttest-3.25/source/lib/queuesystem/masterprocess.py", line 844, in handleRequestFromHost
    self.connection.shutdown(socket.SHUT_RD)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/socket.py", line 224, in meth
    return getattr(self._sock,name)(*args)
error: [Errno 57] Socket is not connected
----------------------------------------

Emily Bache (emily-bache) wrote :

There is a simple workaround - if you use the flag "-l" it runs the tests locally without the aid of a local queue. For small numbers of tests, this is actually faster than usign the local queue.

Also, when I run against trunk, the error message is different, I get:

Failed to submit to local queue (Failed to start slave process : [Errno 2] No such file or directory)

Geoff Bache (geoff.bache) wrote :

I believe this issue is Mac-specific, as I cannot reproduce it on either Linux or Windows.

The "Failed to submit to local queue" issue is probably due to running with a relative path, which I believe is already reported elsewhere.

Geoff Bache (geoff.bache) wrote :

Thanks for patch, committed now.

Changed in texttest:
status: New → Fix Committed
Changed in texttest:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers