packet parsing error with fuelclient test suite

Bug #1504310 reported by Robert Collins on 2015-10-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Testrepository
High
Unassigned

Bug Description

very weird - can trigger an error w/in testrepository but the underlying streams validate with e.g. subunit-ls.

to reproduce
checkout stackforge/python-fuelclient hash d04bb647f49d3d5f64df22e20ed679bbae443f16 (e.g. from https://review.openstack.org/#/c/227895/8)

run fuelclient.tests.unit.v2.cli.test_node.TestNodeCommand.test_node_set_name from that repository under testr:

tox -epy34 -- fuelclient.tests.unit.v2.cli.test_node.TestNodeCommand.test_node_set_name

(or tox -epy34 --notest; . .tox/py34/bin/activate; testr run ...)

running=OS_STDOUT_CAPTURE=1 OS_STDERR_CAPTURE=1 OS_LOG_CAPTURE=1 ${PYTHON:-python} -m subunit.run discover -t ./ ${OS_TEST_PATH:-./fuelclient/tests/unit} --load-list /tmp/tmpsnr20gp_ | tee output
======================================================================
FAIL: subunit.parser
tags: worker-0
----------------------------------------------------------------------
Binary content:
  Packet data (application/octet-stream)

Parser Error: {{{Bad checksum - calculated (0xb97e4a06), stored (0x73202020)}}}
Ran 2 tests in 0.482s (+0.180s)
FAILED (id=33, failures=1)

I captured a stream (attached) using tee in .testr.conf, and it appears valid - no errors from subunit-ls etc.

Robert Collins (lifeless) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers