corrupt streams with designate py34 branch tests

Bug #1474250 reported by Robert Collins on 2015-07-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Testrepository
High
Unassigned

Bug Description

https://github.com/kiall/designate-py3 2b135d64bb0ced77327a563e037b270d1e5ca308

tox -epy34 -- designate.tests.test_agent.test_backends.test_bind9.Bind9AgentBackendTestCase.test_create_domain generates parser errors.

put | cat into the end of the test command in .testr.conf and it works.

ditto | tee -a.

affected:
testr 34 backend 34
testr 27 backend 34

not affected
testr27 backend 27
testr34 backend 27

So this looks to be an interaction between testr's reading behaviour, and subunit.write's writing behaviour.

Changed in testrepository:
status: New → Triaged
importance: Undecided → High

Hi Robert,

Thanks, i tried to run the command "tox -epy34" at my end with below changes:
my .testr.conf content is as below:
==========
[DEFAULT]
test_command=OS_STDOUT_CAPTURE=${OS_STDOUT_CAPTURE:-1} \
             OS_STDERR_CAPTURE=${OS_STDERR_CAPTURE:-1} \
             OS_LOG_CAPTURE=${OS_LOG_CAPTURE:-1} \
             OS_DEBUG=${OS_DEBUG:-1} \
             OS_TEST_TIMEOUT=${OS_TEST_TIMEOUT:-160} \
             ${PYTHON:-python} -m subunit.run discover -t ./ ./designate/tests $LISTOPT $IDOPTION|cat

test_id_option=--load-list $IDFILE
test_list_option=--list
==========

I am getting the exception mentioned at "http://paste.openstack.org/show/376878/".

Robert Collins (lifeless) wrote :

Thats a bug in subunit-trace unrelated to this.

You might try putting a space around the |, in case this is something masked being exposed.

Hi Robert,
Thanks for the suggestion,
I tried by putting the space around "|" but it did not work, getting the same exception as in http://paste.openstack.org/show/376878/. Any idea on fixing this new issue?

Dave McCowan (dave-mccowan) wrote :

Anything new on this? I'm seeing the same error message in Barbican with py34.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers