Terra Terminal Emulator

Terra Terminal Emulator does not support multiple monitors

Reported by Alin Andrei on 2012-12-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Terra Terminal Emulator
Undecided
Unassigned

Bug Description

Terra Terminal Emulator does not support multiple monitors: it always shows up on my secondary monitor. It would be great if it would open on the currently active monitor or if there was an option in its preferences to select which monitor to use.

Also, probably because the lack of multi-monitor support, setting the window width to 48% and horizontal alignment "center", the window is not centered and not 48% as you can see in the screenshot: https://dl.dropbox.com/u/1113424/terra.png

Özcan ESEN (ozcanesen) on 2012-12-05
Changed in terra:
status: New → Confirmed
Alin Andrei (nilarimogard) wrote :

Any news on this?

Özcan ESEN (ozcanesen) wrote :

Hey actually i can't fix this until today because i was on dorm and there is no monitor only laptops and i'm happy to fix this finally, I added Monitor selection combobox to prefences window you can select which monitor do you want to show terra or you can select "always use primary monitor".

And this is still in development, can be difference between window managers, I'm using mutter based gala and works great

Example screenshots: http://screencloud.net/img/screenshots/49ebae7d348c8c5da7ebcddaf6fc1757.png

Changed in terra:
status: Confirmed → In Progress
Özcan ESEN (ozcanesen) wrote :

I will keep this "in progress" until i complete tests in different window managers and specific situations.

Alin Andrei (nilarimogard) wrote :

Thank you, it also works with Unity (Ubuntu 13.04)!

Özcan ESEN (ozcanesen) on 2013-03-05
Changed in terra:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers