Alt-arrows doesn't work with terminal seperator size=0

Bug #562039 reported by Adam Ehlers Nyholm Thomsen on 2010-04-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Terminator
Medium
Chris Jones

Bug Description

When having set terminal seperator size to 0, using Alt-Arrows does not work, however switching terminals using ctrl-shift-n/p works perfectly(at least in trunk). I get this using both 0.90, 0.92 and trunk r996. I have tried from a clean config(rm ~/.config/terminator/config) and it still gives the same behaviour.

Steps to reproduce:
1. Start from clean config
2. Set terminal seperator size to 0
3. Restart terminator to be sure
4. Create new windows using ctrl-shift-E/O
5. Try to navigate using Alt-Arrows

Expected behaviour:
It changes between the created windows

What happens:
Nothing

Extra note:
Just now I noticed a single case where it works as expected, or kinda. If I do ctrl-shift-o, ctrl-shift-e, ctrl-shift-e, then I can change between the lower leftmost and lower rightmost windows.

Related branches

One possible fix is to use weak comparisons(i.e. <= and >= rather than < and >) in get_nav_possible, that seems to fix the issue on my computer.

Chris Jones (cmsj) wrote :

That seems like a reasonable change, thanks :)

Changed in terminator:
status: New → Triaged
importance: Undecided → Medium
milestone: none → 0.93
Chris Jones (cmsj) wrote :

This is fixed in trunk r999 and will be in 0.93. Thanks for the report and feedback!

Changed in terminator:
status: Triaged → Fix Committed
assignee: nobody → Chris Jones (cmsj)
Chris Jones (cmsj) on 2010-04-16
Changed in terminator:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers