'handle_size=0' Results In Very Weird Behavior

Bug #552779 reported by l-x-l on 2010-03-31
This bug affects 2 people
Affects Status Importance Assigned to Milestone

Bug Description

Selecting ‘handle_size=0′ results in very weird behavior. When splitting vertically, the new terminal opens 3/4 of the way to the right instead of splitting the terminal in the middle. When splitting horizontally, the new terminal opens 2/3 of the way to the bottom instead of splitting the terminal in the middle.
This bug is related to version 0.90.

Chris Jones (cmsj) on 2010-03-31
Changed in terminator:
status: New → Confirmed
Chris Jones (cmsj) on 2010-04-02
Changed in terminator:
milestone: none → 1.0-beta
Chris Jones (cmsj) wrote :

This is definitely a functional regression from 0.14, but I'm not yet sure what's causing it.

Kejope (kejope) wrote :

1. Ubuntu Karmic. python-vte 1:0.22.2-0ubuntu2.1. Terminator 0.95ppa2. Compiz and Gnome
2. Ubuntu Lucid. python-vte 1:0.23.5-0ubuntu1.1. Terminator 0.93-0ubuntu1. Metacity and Gnome
(Weird. The Terminator version for Lucid is lower than that for Karmic. Both are installed via Launchpad ppa.)

I do not see the described behaviour.

Christian Helmuth (chelmuth) wrote :

I can confirm this behavior with 0.95 from ppa. Scroll bars must be switched off. If I switch them on (via context menu) split works as expected.

Stephen Boddy (stephen-j-boddy) wrote :

Confirmed still present (or a variation of it) in Version 0.96
With or without scroll bars for me!
Handle size set to 0 or 1 (-1 or 2 or higher does not show issue)
I do a Ctrl-o, then a Ctrl-e
On the Ctrl-e the horizontal splitter from the Ctrl-o jumps up, almost as if redistributing 3 vertically stacked terminals.

Chris Jones (cmsj) on 2012-10-18
Changed in terminator:
milestone: 1.0 → none
importance: Undecided → Low
Stephen Boddy (stephen-j-boddy) wrote :

I just retested this and it all works without strange effects. I think it must have been fixed by other commits. I think it can be closed, unless the OP can still reproduce.

Stephen Boddy (stephen-j-boddy) wrote :

Hi Bug subscribers, this is the maintainer (Steve Boddy) of Terminator, who took over from Chris.

In case you were not aware there has been a new release 0.98 of Terminator in the last few days which has many changes, fixes and updates. We also have an ongoing GTK3 port which uses a much more up-to-date libvte.

Even with the ~50 issues closed by that release, and discounting the ~90 outstanding wishlist items, we still have an unwieldy 95 bugs. With the oldest approaching it's 6th birthday and some that haven't seen any updates in nearly 5, it is time for a purge.

My intention is to try and get this list down to a minimum, and for that I need your help.

First I'm going to work through, oldest to newest, setting bugs to Incomplete, pending confirmation that they are still an issue. If after a month there is no feedback, the issue will get closed as Invalid. Here's where you come in. I can't always reproduce, or setting up (i.e. other distros) to even test takes a long time, so I'm going to try crowdsourcing this.

1. Get the latest release. Is it still an issue? If yes, set the confirmed-0.98 tag. For bonus points follow the guide http://gnometerminator.blogspot.com/2015/09/so-you-want-to-try-terminator-gtk3.html and see if the GTK3 branch has same issue, and set the confirmed-gtk3 or notaffected-gtk3 tag.

2. Can you reproduce with an empty/default config file? You can pass "-g temp_config" to do this without affecting your existing config. If you already have Terminator running, you'll need to pass -u as well to disable the DBus.

3. If able to, can you reproduce with another user/guest account?

4. If the issue does not already have clear, precise instructions to reproduce with minimal setup/steps, add them.

5. Put as much info about what you are running.
   * Software/library versions (libvte, gtk, pango, cairo, distro, desktop environment, language)
   * Screens (single or multi)
   * Any unusual / custom packages or configs that might be interacting.

6. If possible attach the config file, unless the issue also happens with an empty one, but mention that.

7. Attach the "-d" debug output from 0.98.

Some common things that cause incidents.

* Strange sizing issues or rapidly shrinking windows - Try turning off Window geometry hints.
* Input (esp. broadcasting duplicate chars etc) problems - Try killing IBus.
* Hand editing of the config file can cause various issues - Due to misunderstanding, incorrect structure or typos.
* Some issues are actually in libvte - This is why testing GTK3 is so important.
* segfaults - Unfortunately these are dying inside the C libraries, and it is usually beyond me to fix those.

Many thanks for your assistance, and hopefully this will get us closer to a bug-free Terminator.

Changed in terminator:
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers