Titlebar doesn't hide completely

Reported by Rémi Rérolle on 2010-03-31
56
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Terminator
Wishlist
Unassigned

Bug Description

On version 0.90, when unchecking the "Show titlebar" option in the preferences, a small part (about 2 pixels) of the titlebar remains visible (tested on karmic with the version from the PPA)

The attached patch fixes this, though I'm not aware if it's the correct way to do it.

Rémi Rérolle (remi.rerolle) wrote :
description: updated
Chris Jones (cmsj) wrote :

So the current behaviour is fairly deliberate - since the grouping feature relies on colour and the grouping menu is only accessible from the titlebar, I wanted to leave a tiny hint of the colour and a very small clickable area.
Previous iterations had a 2px border around the whole terminal and no access to the grouping menu, which seemed to be much worse all round.

I'd really like to find a way to not hide information from people about the grouping - I think it's important to know if a terminal is going to receive/send keystrokes to other terminals, but I'm very willing to discuss how we can achieve this in a way that keeps the no-titlebar crowd happy :)

Changed in terminator:
status: New → Incomplete
importance: Undecided → Wishlist
Rémi Rérolle (remi.rerolle) wrote :

Well currently it really looks like something is wrong when the titlebar is hidden...this 2 pixels wide line seems out of place.

Maybe it would be possible to have the titlebar auto-hide and only appear when the mouse cursor is hovering over it. Though my guess is that such an implementation would require quite a lot or work.

kinji (maxime-hadjinlian) wrote :

I also found this 2 pixels bar to be annoying.

Maybe there should be a "super" hide titlebar option so the user can choose for himself if we wants to see this indication or not.

I'm not using the grouping feature so to me it was really like something was wrong as Remi said.

Rémi Rérolle (remi.rerolle) wrote :

In fact I realized what I found the most disturbing is that not only a thinner titlebar is displayed, but also a small part of the icon and the separator that sits next to it...maybe hiding the icon and separator as well would provide a cleaner look without much effort, yet keeping the visual group hint.

Chris Jones (cmsj) wrote :

Remi: keeping the icon slightly visible was also deliberate, because its still clickable to get the grouping menu.

So as a general point I'm prepared to accept the desire for fully hidden titlebars. I think it's a bit excessive, but whatever. However, I want to do it in a way that's sane from a usability and code complexity perspective and this bug seems like an idea place to discuss the possibilities.

I think my best suggestion right now would be:

 * Grouping menu appears in the context menu if the titlebar is hidden
 * terminal backgrounds get a subtle coloured tint to reflect group receive status (not transmit status, you'll be on your own for which terminal has focus).

I've not looked into exactly how easy the second part of that would be to do, but I'm pretty sure the first part is do-able without too much drama.

corenominal (corenominal) wrote :

A conditional grouping menu appearing in the context menu seems like the most sensible option to me. :)

Regarding whether the titlebar should be fully hidden or not, I think that if the user selects the option to have it hidden, then the program should honour this. Maybe another alternative would be to have a 'titlebar margin width' option available from within the preferences dialog? This way the user could decide if they want the titlebar fully hidden or not. Some window managers provide a similar option so that users can easily allocate space for accessing their right-click system menus. Just a thought. :)

I have to agree that just a check box for maybe 'Fully hide title bar' would be excellent.

I'd also like to see this doable as an option that can be passed. Such as --no-title or --partial-title.

Although - a profile could suffice for this as well as long as the profile can be picked from launching it. I assume this is possible but way too tired to check.

"you'll be on your own for which terminal has focus"
With no title bar, I fully agree on this. Thankfully the cursor gives it away. :)
I also have my own fun way of dealing with that and have my own reason for not wanting the title: full screen, not overlapping icon tray/clock, having a lot of space.

Mostly wanted to say that I agree this is a good assumption to have (that we'll be expected to manage it ourselves).

Jeff Kowalczyk (jfkw) wrote :

+1 on a no-title-bar preference if the user is prepared to accept the limitations. I don't do anything in terminator that I don't have keybinding for (i.e. I split only, never tried grouping). My preference with my tiling window manager is to have no decorations rendered surrounding the terminal text.

Also +1 for related options to choose a 1-pixel divider line between split terminals. I presume this is 'terminal separator size'. At bzr trunk r976, the terminal-separator size slider goes from -1 to 0 to 1, but value -1 had a multipixel white (not the desired color) divider, 0 or 1 (and higher I presume) render a zero-pixel divider, unless that pixel is background color black and I just can't see it.

Thanks.

Chris Jones (cmsj) wrote :

I'm confirming this and targetting it to 1.0. We'll figure out how to do this in such a way that everyone wins.

Changed in terminator:
status: Incomplete → Confirmed
milestone: none → 1.0-beta
PiranhA (ghostmail) wrote :

For me hiding the titlebar with "titlebars = false" doesn't work at all with the latest release.
I'm using Ubuntu Lucid Lynx 64bit with Terminator 0.93 (http://ppa.launchpad.net/gnome-terminator/ppa/ubuntu).
I have the same problem on an other pc with Ubuntu Karmic and the same version of Terminator.

Idea for visually notifying the user that tabs are grouped:
You could do as the "Group Windows" plugin for Compiz does, ie have a colored border for the terminal.

Dominic Hopf (dmaphy) wrote :

Can confirm this issue for Terminator 0.93. There are some Fedora users claiming this as well. :)

Hi

On 31/03/10 16:23, Remi REROLLE wrote:
> On version 0.9, when unchecking the "Show titlebar" option in the
> preferences, a small part (about 2 pixels) of the titlebar remains
> visible (tested on karmic with the version from the PPA)

The discussed solution is now partially implemented in trunk by revision
1019. The titlebar remains hidden until the following states are present:

 1) a group name is being created
 2) the terminal is in a group

I think 1) will always be the case, but eventually I hope to address 2)
with colour hinting of the terminal background.

Cheers,
--
Chris Jones
  <email address hidden>
   www.canonical.com

Chris Jones (cmsj) on 2010-07-14
Changed in terminator:
status: Confirmed → Fix Released

I was about to report a bug for this - good to see it fixed already! (I hadn't noticed because the Ubuntu Lucid packages are not updated - but the Maverick ones work fine on Lucid).

For anyone else who finds this page via Google the relevant option is "show_titlebar = False".

"handle_size = 1" also sets a single pixel divider (as mentioned by Jeff Kowalczyk above).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments