Watch for activity and watch for silence

Bug #343616 reported by Kai Grossjohann
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Terminator
Wishlist
Chris Jones

Bug Description

WIBNI Terminator could watch for activity or silence in a specific shell (terminal? pane?)?

Both would set the urgent hint on the window when the condition is met.

"Watch for silence" is useful in the following scenario: Suppose you have a long-running job that produces output while it is running, for example building some software. Then it would be cool to select the "Watch for silence" action. This would continuously monitor activity in the terminal, and when no output arrives for some configurable time, it would mark the window as urgent so that it flashes in the Gnome taskbar.

"Watch for activity" complements "watch for silence" and is useful for long-running jobs that seldom produce output, and you want to be alerted when output happens. Perhaps "tail -F /some/log/file | grep SomePattern" is a typical example.

Related branches

Revision history for this message
Chris Jones (cmsj) wrote :

This ought to be possible with the signals that VTE provides.

Changed in terminator:
importance: Undecided → Wishlist
status: New → Confirmed
Revision history for this message
Chris Jones (cmsj) wrote :

0.94 is now released and includes a plugin that monitors for terminal activity, but there is not yet one that monitors for silence (just because that's a bit harder to write ;)

Changed in terminator:
status: Confirmed → In Progress
Revision history for this message
Chris Jones (cmsj) wrote :

a plugin that monitors for silence is now in trunk at revision 1224 and will be in 0.96

Changed in terminator:
status: In Progress → Fix Committed
assignee: nobody → Chris Jones (cmsj)
Changed in terminator:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions