[0.9] XDG_CONFIG_HOME is not properly handled

Bug #247893 reported by chantra on 2008-07-12
8
Affects Status Importance Assigned to Milestone
Terminator
Undecided
chantra

Bug Description

It appears that XDG_CONFIG_HOME is not properly handled.
The issue only happens when XDG_CONFIG_HOME is already set (ark linux for instance).
A workaround is to start terminator with the following:
$ XDG_CONFIG_HOME=~/.config/terminator/ terminator

chantra (chantra) wrote :

Fixed in trunk rev 433

Changed in terminator:
assignee: nobody → chantra
status: New → Fix Committed
chantra (chantra) wrote :

linking to nilestone 0.9.1 for tracking purpuse

Changed in terminator:
milestone: none → 0.9.1
Chris Jones (cmsj) on 2008-09-02
Changed in terminator:
status: Fix Committed → Fix Released
darthwonka (mrb-ciclops) wrote :

I don't think this has been fixed completely.

I have 5 or 6 gnome profiles I use for various systems I log into.
When using terminator, the profile font settings are ignored.

The workaround is the same.

XDG_CONFIG_HOME=~/.config/terminator/ terminator --profile WS ...

With the workaround, the profile fonts are correct.

version: terminator 0.11 from Fedora 10

Chris Jones (cmsj) wrote :

darthwonka: could you please run that same command with -d and then run it without the XDG_CONFIG_HOME, with -d and attach the results?

darthwonka (mrb-ciclops) wrote :

Attachment is the output you requested.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions