Insert number doesn't work on Ubuntu 18.04

Bug #1812953 reported by Danti Felicita Anjani on 2019-01-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Terminator
Undecided
Unassigned

Bug Description

I got this error whenever I tried to insert_number. I had changed the keybinding several times and still got the same error.

Traceback (most recent call last):
  File "/usr/share/terminator/terminatorlib/terminator.py", line 642, in do_enumerate
    term.feed(numstr % (idx + 1))
  File "/usr/share/terminator/terminatorlib/terminal.py", line 1507, in feed
    self.vte.feed_child(text, len(text))
TypeError: Vte.Terminal.feed_child() takes exactly 2 arguments (3 given)

Egmont Koblinger (egmont-gmail) wrote :

See e.g. https://bugs.launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+bug/1780501 for details.

VTE indeed silently fixed the python binding to take 2 arguments instead of 3, causing such a backward incompatible breakage. As far as mainstream Terminator is concerned, it should try-except, or just require a new enough VTE and go with the fixed API.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers