Terminator broadcasts to other terminator processes as well

Bug #1751270 reported by Vincent Ouwehand on 2018-02-23
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Terminator
Undecided
Unassigned

Bug Description

When using terminator i used to have multiple separate instances of terminator running. I could then split and group the various sections in each instance without each interfering with another. Today i ran into the (unpleasant) surprise that 1 instance of Terminator would broadcast to all other instances on my desktop.

I run:
Xubuntu 17.10 (XFCE)
Terminator 1.91-1

This behavior is a dangerous change and has caused quite some havoc at my work already, costing me 4 hours of work due to one of the unfocused (and hidden behind other windows) instances cancelling an upgrade script that had been working for hours.

Expected behavior; Broadcast stays within the terminator instance.

Reproduction steps:
1. Open terminator and split screen in preferred way.
2. Open second terminator and split screen in preferred way
3. Group all terminals in the terminator session using Super+G as hotkey
4. Turn on group broadcast on either terminator session and type.

You will now type in both terminator sessions against expectations.

There was no output with terminator -d

Config file attached

Cannot get bazaar ppa to work on xubuntu, the repo doesn't seem to work so cannot test the latest version.

Vincent Ouwehand (4e0a8aa4) wrote :
description: updated
hijglander (robintol) wrote :

I have the same issue and suspect everyone does... unless there is some magical config setting we don't know about.

Anyway, I've found this same bug to be there on Fedora and Ubuntu alike.

To reproduce just open two terminator windows and enable "Broadcast to all".

A workaround is using groups and "Broadcast to group"... Not really the desired solution but it is doable.

PC1: Debian (Testing release) 9
     Desktop: MATE 1.20

PC2: Fedora 27
     Desktop: MATE 1.16

The terminator version is on both the latest available thru the repositories: 1.91

hijglander (robintol) wrote :

Forgot to mention that both Fedora and Debian installs are default, no config changes have been made to terminator so everything is vanilla.

hijglander (robintol) wrote :

Also another thing to note is that only one ("1") terminator process shows up in the lists of processes. I'd expect each terminator window to have it's own, but that's just me thinking.

hijglander (robintol) wrote :

Damn... the solution is to disable the "DBUS server" in Preferences.

No longer a BUG!

Vincent Ouwehand (4e0a8aa4) wrote :

OMG, you are my hero @hijglander Applying that setting tomorrow morning immediately !

Changed in terminator:
status: New → Invalid
hijglander (robintol) wrote :

:-) You're welcome, but I can't take the credit... found the solution here: http://terminator-gtk3.readthedocs.io/en/latest/grouping.html?highlight=dbus

bitinerant (bitinerant) wrote :

@hijglander - you're my hero too! Even if you say you can't take credit, your solution is the one I was able to find.

However, I disagree that this is not a bug. It seems the "DBUS server" option is very poorly labeled and should not be on by default. Or maybe it's broken.

Hijg Lander (hijglander) wrote :

😉 nice of you to leave a comment and I’m happy to have been able to help.
I agree the DBUS Server option is rather poorly labeled in the configmenu. Maybe the developers can change it a bit so the option is obvious for us “normal” folks and disable it by default.

Damn... the solution is to disable the "DBUS server" in Preferences.

-> Same as others, your solution is the one I've found.

I've just created an account to be able to THANK YOU for this.

I've been struggling with this without knowing how to fix this.

Thank you very much and have a great day :) @hijglander

hijglander (robintol) wrote :

:-) You're welcome Romain.
I will have a great day, hope you have one (and many more) too.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments