Rectangular grey area around title bar

Bug #1656509 reported by Louis on 2017-01-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Terminator
Undecided
Unassigned

Bug Description

After updating to the new GTK3 version of Terminator there's a rectangular grey area around title bar.

I've looked trough settings but there seems to be no way to disable this.

Louis (louis-louis) wrote :
Stephen Boddy (stephen-j-boddy) wrote :

Louis, are you using a packaged 1.90 or the gtk3 branch head? I've seen that exact effect due to theming when trying to fix the transparent backgrounds (https://bugs.launchpad.net/terminator/+bug/1599453). I fixed all the bad interactions I could find in the head of gtk3, but they are not yet in an official release yet. Can you take a look? It might also help to know what theme you are running.

Changed in terminator:
status: New → Incomplete
Louis (louis-louis) wrote :

I'm using Arch Linux with terminator gtk3 branch at version r1702, Gnome shell build r1702 and the vertex theme version 20161009. If I switch to an another theme like Adwaita the issue is still present.

description: updated
Louis (louis-louis) on 2017-01-30
Changed in terminator:
status: Incomplete → New
Stephen Boddy (stephen-j-boddy) wrote :

Then that's very strange. I fixed this exact symptom for Adwaita already in:
https://bugs.launchpad.net/terminator/+bug/1599453
If you search down through the comments you will see me mention the grey box around the title bar under Adwaita. I spent quite a bit of time finding and fixing various transparent rendering issues, culminating in the merge of a decent chunk of work:
http://bazaar.launchpad.net/~gnome-terminator/terminator/gtk3/revision/1672
Specifically for this issue the fix was in terminatorlib/terminator.py, lines 417-424.
That change fixed the rectangle for myself and the OP on 3.18. It makes no sense that it doesn't work for you, as it is a cross theme fix, and you are on a newer gtk. The best I can suggest is that you use:
GTK_DEBUG=interactive terminator -u
and see if you can find exactly what element in the hierarchy is introducing the grey box for you. Otherwise it's a case of randomly making changes in a probably futile attempt to fix it.

Changed in terminator:
status: New → Incomplete
Stephen Boddy (stephen-j-boddy) wrote :

Louis, can you check with an up-to-date branch with rev. 1714. That rev is merging in a change for GTK 3.20+ where CSS selectors now have to use nodes. One of the changes needed in this rev would explain why you still experience an issue I already fixed. (Note that, yet again, the breakage is because Gnome like to change stuff for the hell of it.)

For more detail: https://code.launchpad.net/~laney/terminator/gtk3.20-embedded-css/+merge/316094

Louis (louis-louis) wrote :

This issue has been resolved in branch r1714. Thanks!

Changed in terminator:
status: Incomplete → Fix Committed
Changed in terminator:
milestone: none → 2.0
Changed in terminator:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments