System fixed font doesn't correct

Bug #1655446 reported by Juan Simón on 2017-01-10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Stephen Boddy

Bug Description

Arch linux 64 bits
GNOME Shell 3.22.2 on Wayland
terminator-gtk3-bzr r1695-1 (installed from AUR package: )

See screenshot. I have defined as system fixed font: Source Code Pro (using gnome-tweak-tool > Fonts) but when I click in "Use the system fixed width font" (in Terminator preferences), it uses "Monospace Regular 10", why? Where does this data come from?

Related branches

Juan Simón (simonbcn) wrote :
Stephen Boddy (stephen-j-boddy) wrote :

The gtk3 port was a straight "get it to run under gtk3" but proper integration with the gtk3 desktop was a secondary thing. So the code to detect the system fonts is still using GConf and the settings in /desktop/gnome/interface/monospace_font_name

The Gnome Shell is going to be using DConf to store its settings, so when you change the setting in whatever GUI settings program you have, it is updating DConf, not the GConf. (/org/gnome/desktop/interface/monospace-font-name) So Terminator doesn't see the change. Instead Terminator will use GConf if available, or if the path doesn't exist it will default to a "Mono 10" string.

I have a change that reads the DConf setting, but I need to figure out the call required to detect external changes to the key. At the moment that bit does not work.

Changed in terminator:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Stephen Boddy (stephen-j-boddy)
Stephen Boddy (stephen-j-boddy) wrote :

Committed revision 1697.

OK, So I've committed code that works now. Having fixed it, I'm not even sure the original code was changing the font immediately when using gtk2/gconf, as the logic appeared to be messed up.

Changed in terminator:
status: Triaged → Fix Committed
Juan Simón (simonbcn) wrote :

👍 it works now. Thanks.

Changed in terminator:
milestone: none → 2.0
Changed in terminator:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments